

                               Information and Communication

INTERNET.

Why Study about the Internet?
· To understand what the Internet is, the services that it offers, what is required in order to get connected, as well as to establish a connection and log out of the Internet.
What is the Internet?

· It is a large no. of connected computers (or a large set of computer networks) linked together that communicate with each other, over telephone lines.  

· It is a worldwide computer network connecting thousands of computer networks, through a mixture of private & public data using the telephone lines.

· It is a worldwide (global or an international) network of computers that provide a variety of resources and data to the people that use it.

· Internet refers to a global inter-connection of computers and computer networks to facilitate global information transfer.  It is an interconnection of computers throughout the world, using ordinary telecommunication lines and modems.

The Internet uses VSATS (Very Small Aperture Telecommunication Systems) such as Telephone lines, Satellite.

The other names for the Internet are:

· The Net.
· Information Superhighway. 
· Cyber space.
Internet is a facility that links the Internet users to the actual Internet documents.  Therefore, it is a system that links together many kinds of information all over the world.  This technology allows computers equipped with telecommunication links to exchange information freely, and as such, the Internet has enhanced what is being referred to as a global village.
Internet enables companies, organizations, individuals, schools and governments to share information across the world.

A computer on the Internet can be located anywhere in the world.  The Internet enables the computer to communicate with any other computer.
HISTORY (DEVELOPMENT) OF THE INTERNET.

The Internet was started by the U.S Department of Defence in 1969 as a network of 4 computers called ARPANET.  Its aim was to connect a set of computers operated by several Universities and Scientists doing military research so as to enable them share research data.
The original network grew as more computers were added to it.  By 1974, 62 computers were already attached.  

In 1983, the Internet split into 2 parts; one dedicated exclusively (solely/only) to military installations (called Milnet), and the other dedicated to university research (called the Internet), with around 1,000 host computers.

In 1985, the Canadian government developed the BITNET to link all the Canadian Universities, and also provided connections into the U.S Internet.  
In 1986, the U.S National Service Foundation created NSFNET to connect leading U.S universities.  By the end of 1987, there were 10,000 host computers on the Internet and 1,000 on BITNET.
In 1987, the National Science Foundation leased (acquired/rent) high-speed circuits to build a new high-speed backbone for NSFNET.  In 1988, it connected 13 regional internal networks containing 170 LAN’s and 56,000 host computers.  
The Canadian Research Council followed in 1989, replacing BITNET with a high-speed network called CA*net that used the Internet protocols.  By the end of 1989, there were almost 200,000 host computers on the combined U.S and Canadian Internet.

Similar initiatives (plans/projects) were undertaken by other countries in the world, such that by the early 1990s, most of the individual country networks were linked together into one worldwide network of networks.  
Each of these individual country networks was different (i.e., each had its own name, access rules, and fees structure), but all the networks used the same standard as the U.S Internet network.  So, users could easily exchange messages with each other.
By 1990s, the differences among the networks in each of the countries had disappeared, and the U.S name; Internet began to be used to mean the entire worldwide system of networks that used the Internet TCP/IP protocols. 
A Protocol - a set of rules and standards that computers use to communicate with each other over a Network.

Features of the Internet.
(i). The Internet is a collection of networks; it is not owned or controlled by any single organization, and it has no formal management organization.  However, there is an Internet Society that co-ordinates and sets standards for its use.  
In addition, Networks have no political boundaries on the exchange of information.

(ii). Networks are connected by Gateways that effectively remove barriers so that one type of network can “talk” to a different type of network.

(iii). To join the Internet, an existing network will only be required to pay a small registration fee and agree to certain standards based on TCP/IP.  
The costs are low, because the Internet owns nothing, and so it has no real costs to offset.  Each organization pays for its own network & its own telephone bills, but these costs usually exist independent of the Internet.
(iv). Networks that join the Internet must agree to move each other’s traffic (data) at no charge to the others, just as it is the case with mail delivered through the International Postal system.  This is why all the data appear to move at the cost of a local telephone call, making the Net a very cheap communication media.
FUNCTIONS OF THE INTERNET.
The Internet carries many kinds of traffic, and provides users with several functions.  Some of the most important functions are:

1. Communication.

Many people all over the world use the Internet to communicate with each other.

Internet communication capabilities include; E-mail, Usenet Newsgroups, Chatting and Telnet.  You can send e-mails to your friends anywhere in the world, chat with your friends, send instant messages, etc.

2. Information retrieval.

The Internet is a library.  Thousands of books, magazines, newspapers and encyclopedias can be read on the Internet.

3. Easy-to-use offerings of information and products.

You can find information for your school assignments, buy books online, check what the weather is like anywhere in the world, and much more.
INTERNET SERVICES.

The following are some of the services offered by Internet:

(i). Electronic mail (e-mail).

(ii). Fax services.

(iii). Conference services.
(iv). Online chatting.

(v). Downloading of programs.

(vi). Online shopping.
(vii). File transfer.

(viii). Entertainment (Games, Music and Movies).

(ix). Free information retrieval (e.g., Educational information).
(x). Formation of Discussion groups, e.g. Usenet Newsgroups.
(xi). Video Conferencing.

(xii). Access & Use of other computers.

Electronic Mail (E-mail).

An E-mail is a system that enables sending & receiving of messages electronically through computers.  It is used for communication between organizations or departments in the same organization.
E-mail is a quick, cheap, efficient & convenient means of communication with both individuals and groups.  It is faster than ordinary mail, easy to manage, inexpensive and saves paper.
With Internet mail, it is possible to send and receive messages quickly from businesses, friends or family in another part of the world.  An E-mail message can travel around the world in minutes.
Fax services.

Fax services enable individuals & businesses to send faxes through e-mail at a lower cost compared to the usual international Fax charges.

Conference services.

Conferencing on the Web can be defined as the dynamic exchange of all kinds of information – text, graphics, audio, video, etc – in a situation whereby the conversations are organized by item and allows a participant to contribute spontaneous responses to any item in the conversation.

Application of Conferencing on the Web.

The conversation can:

· Provide important information that can assist in decision-making.

· Provide any required technical support.

· Help in community-building, project management & distance learning.

· Help to organize electronic meetings, etc.

The Internet also allows you to have access to various types of information you might require to make accurate and informed decisions, E.g., it provides information on business, education, sports, politics, etc.

Chatting.

Internet Relay Chat (IRC) is a chatting system on the Internet that allows a large no. of people from various locations of the world who are on the computer to chat (i.e., simultaneously hold live and interactive electronic conversations) among themselves.
You can join discussion groups on the Internet and meet people around the world with similar interests.  You can ask questions, discuss problems and read interesting stories.

Anyone interested in chatting can join a discussion forum on one of the listed topics.  Only people who happen to be signed on at the same time are able to talk because messages are not stored.
This discussion can be an effective business tool if people who can benefit from interactive conversation set a specific appointment to meet and talk on a particular topic.
Disadvantage.

(i). Usually, the topic is open to all without security; so intruders can participate.

Information retrieval.

The Internet is a voluntarily decentralized network with no central listing of participants or sites.  Therefore, End-users, usually working from PCs are able to search & find information of interest located in different sites assisted by special software and data stored in readily usable formats.

The Internet gives you information on almost any subject.  This is because of the Worldwide Web (www).  
The World Wide Web is a global (an international) system of connected Web pages containing information such as, text, pictures, sound and video.  The WWW is hypertext based (i.e., it is able to access text and graphical data formatted for easy search, retrieval and display).
With the WWW, you can review Newspapers, magazines, academic papers, etc.  In addition, Governments, colleges, universities, companies and individuals offer free information on the Internet.  E.g., you can inquire (find out) about universities in Britain or America.
Note.  Its major problem is finding what you need from among the many storehouses of data found in databases and libraries all over the world.

Dowloading of Programs.

There are thousands of programs available on the Internet.  These programs include; Word processors, Spreadsheets, Electronic cards, etc.   
You can therefore, look for the latest software over the Internet, e.g., you can get the latest Anti-virus software, and in addition, retrieve a free trial issue.

Entertainment.

There are hundreds of simple games available on the Internet.  These include; Chess, Football, etc.  The Internet also allows you review current Movies and hear Television theme songs.
Online Shopping.

You can order goods and services on the Internet without leaving your desk.  E.g., you can view a catalogue of a certain clothes shop over the Internet and fill in an online Order form.
Commercial enterprises use the Web to provide information on demand for purposes of customer support, marketing and sales.
File Transfer.

Data in the form of files can be transferred across the Internet from one site to another using the File Transfer Protocol (FTP).  FTP software is needed at both ends to handle the transfer.  It is through FTP that the two pieces of software manage to ‘understand’ each other.

Discussion Groups.

A Discussion group is a collection of users who have joined together to discuss some topic.

There are many discussions on different topics including Cooking, Skydiving, Politics, Education, recreational, scientific research, etc.

Two of the commonly used discussion groups for business are;

· Usenet newsgroups.

· List Servers.

(a). Usenet newsgroups.

These are the most formally organized of the discussion groups.

Using a facility on the Internet called USENET, individuals can gain access to a very wide variety of information topics.

Usenet Newsgroups are usually worldwide discussion groups in which people share information and ideas on a defined topic through large electronic Bulletin Boards where anyone can read any articles or write articles and post messages on the topic for others to see and respond to.

The individuals can add messages to different topics and read those contributed by others. For instance, users such as students can ask questions about problems they face, or they could contribute or give an advice on how to improve the teaching of the subject.

Messages can be easily linked so that it is easy to know messages that are related.

Establishing a new newsgroup requires a vote of all interested people on the Internet.  If enough people express interest, the new topic is established.

Note. To join a Newsgroup and be able to read messages on various topics, your computer must have Newsreader software such as Outlook Express, or Internet News.

Any Internet user can access some of these newsgroups, while other newsgroups will require to subscribe to a specific topic or set of topics.  
Once you have subscribed, each time you access the newsgroups you are informed of any new messages added to the topics.  You can then read these messages and respond to them by adding your own message.

The Usenet software receives “postings” of information and transmits new postings to users who have registered their interest in receiving the information.  Each individual posting takes the form like that used for e-mail.

There are over 10,000 such newsgroups; however, each Usenet site is financed independently & controlled by a Site Administrator, who carries only those groups that he/she chooses.

(b). List Server

A List Server (or list serve) group is similar to the Usenet newsgroups, but is generally less formal.

Anyone with the right e-mail server software can establish a list server, which is simply a mail list.

The processor of the List Server processes commands such as request to subscribe, unsubscribe, or to provide information about the list serve.  The List serve mailer directs messages to everyone on the mailing list.

To use a List server, you need to know the addresses of both the Processor and the Mailer.

To subscribe to a List server, you send an e-mail message to the List server processor, which adds your name to the list.  Many different commands can be sent to the List server processor to perform a variety of functions.  These commands are included as lines of text in the e-mail messages sent to the processor.  

List servers are more focused that the Usenet newsgroups and have fewer members.  They are harder to find than the Usenet newsgroups because literally anyone can create one.

Video Conferencing.

Video conferencing provides real-time transmission of video & audio signals to enable people in 2 or more locations to have a meeting.

The fastest growing form of video conferencing is Desktop video conferencing.  

Small cameras installed on top of each camera enable meetings to take place from individual offices.

Special application software (e.g., CUSeeMe) is installed on top of each client computer.  It transmits the image across a network to application software on a video-conferencing Server.  The server then sends the signals to the other client computers that are to participate in the video conference.  In some areas, the clients can communicate with each other without using the server.

Some systems have integrated other types of GroupWare with desktop video conferencing, enabling participants to communicate verbally to attend the same “meeting” while sitting at the computer in their offices.

Advantage of Video conferencing.

(i). Saves time & cost, as it reduces the need to travel.
Access & Use of other computers.

The Internet has a facility called TELNET that enables a user on one computer to use another computer across the network, i.e., the user is able to run programs on the other machine as if he/she is a local user.
Telnet is a protocol, which enables a user on one computer to log in to another computer on the Internet.

TELNET establishes an error-free, rapid link between two computers, allowing a user to log on to his/her home computer from a remote computer even when traveling.  You can also log on to and use third-party computers that have been made available to the public.
TELNET will use the computer address you supply to locate the computer you want to reach and connect you to it.  You will, of course, have to log in & go through any security procedures you, your company, or the third-party computer owner have put in place to protect that computer.

Telnet requires an application image program on the Client computer and an application layer program on the Server of the host computer.  Many programs conform to the Telnet Standard (e.g., EWAN).

Once Telnet enables the connection from the Client to the Server, you can log in by use of commands.  The exact commands to gain access to these newsgroups vary from computer to computer.

Telnet enables you to connect to a remote computer without incurring long-distance telephone charges.

Telnet can be useful because, it enables you to access your Server or Host computer without sitting at its Keyboard. 

Telnet can be faster or slower than a modem, depending on the amount of traffic on the Internet.

Note.  Telnet is insecure, because everyone on the Internet can attempt to log in your computer and use it as they wish.  One commonly used security precaution is to prohibit remote log ins via Tel-net unless a user specifically asks for his/her account to be authorized for it, or permit remote log ins only from a specific set of Internet addresses., e.g., the Web server at a university can be configured to only accept telnet log ins from computers located on the Kabete Campus network.

Electronic Commerce. 
Many people are actively using the Internet for Electronic Commerce (i.e., doing business on the Internet).

The use of the Internet in E-commerce is not necessary for making money as such, but mainly to find information, improve communication and provide information.

Many people automatically focus on the retail aspect of e-commerce, i.e., selling products to individuals.  However, this is just one small part of e-commerce.  The fastest group and the largest segment of e-commerce is business-to-business settings.

There are 4 ways in which the Web can be used to support E-commerce;

(i). Electronic Store.

Electronic Store is a Website that lists all the products or services a business wishes to sell, thus enabling customers to purchase them by using the Internet itself.  

E-store sites provide physical goods and services.  

The cost of providing information on the Web is low (unlike a Catalog, in which each page adds to the cost), and therefore, electronic stores can provide much information.  In addition, electronic stores can also add value by providing dynamic information.

E-mail can also serve the purpose of E-store.  This is because, e-mail is essentially a collection of e-stores.  The mail usually provides all the computer information needed for e-commerce, and advertises the mail to potential customers.  In return, the stores pay the mail a monthly fee or some percentage of sales.

(ii). Electronic Marketing.

E-marketing sites focus on the products or services of one company with aim of increasing sales.  

This type of site supports the sales process, but does not make actual sales.  The goal is to attract and keep customers.  

By doing so, such sites provide a wealth of information about the firms and products complete with technical details and photos.  Customers can review these but cannot buy over the Web.  The idea is to encourage the user to visit a local dealer, who will then make a sale.  

Computers also use e-marketing sites to provide newsletters with information on the latest products and tips on how to use them.  Other companies enable potential customers to sign up for notification of new product releases.

E-marketing is cheaper in many ways than traditional marketing (radio, direct marketing, TV or print media).  This is because while it costs the same to develop these traditional media, it costs nothing to send information to the customers.  It is also easier to customize the presentation of information to a potential customer, because the Web is interactive.  In contrast, the other media are fixed once they are developed, and they provide the same marketing approach to all who use it.

(iii). Information / Entertainment provider.

The Information/Entertainment provider supplies information (in form of text or graphics) or entertainment.  These providers provide information from many sources with an aim of helping the users.

Several radio and TV stations are using the Web to provide broadcast of audio and video.  The Web also offers new forms of real entertainment e.g., enables new multiplayer interactive games, which are not available in any other media.  The information / entertainment providers generate revenue by selling advertisement printouts.

(iv). Customers Service sales.

This provides a variety of information for customers after they have purchased a product or service – to allow customers access most commonly needed information 24 hrs a day. 

Many software companies post updates that fix problems so that customers can download for themselves.  

Customer service sites benefit both the company and the customers.  They enable customers to get a 24 hr support and easy access to needed information.  

They often reduce the no. of staff needed by automating routine information requests that previously had to be handled by an employee.  

GroupWare.
GroupWare is a software that helps groups of people to work together more productively.

They are often organized using a two-by-two grid.

	Same place
	Same time
	Different time

	
	Group support systems
	Group support systems

	Different place
	Video teleconferencing, Desktop video teleconferencing
	E-mail, Discussion groups, Document-based GroupWare


GroupWare allows people in different places to communicate either at the same time (as on a telephone) or at different times.

GroupWare can also be used to improve communication and decision-making among those who work together in the same room, either at the same time or at different times.

GroupWare allows people to exchange ideas, debate issues, make decisions, and write reports, without actually having to meet face to face.  Even when groups meet in the same room at the same time, GroupWare can improve meetings.

The major advantage of GroupWare is its ability to help groups make faster decisions, particularly in situations where it is difficult for group members to meet in the same room at the same time.

The 3 most popular types of GroupWare are;

· Discussion groups.

· Group support systems.

· Video Conferencing.

Group Support Systems (GSS).

Both e-mail and documents-based GroupWare are designed to support individuals and groups working in different places at different times.  They are not suited to support groups working together at the same time and in the same place.  In addition, they don’t provide advanced tools for helping groups to make decisions.

Group Support Systems (GSS) are software tools, designed to improve group’s decision-making.  GSS are used with special-purpose meeting rooms that provide each group member with a network computer plus a large screen video projection system that acts as electronic blackboards.  These rooms are equipped with special-purpose GSS software that enables participants to communicate, propose ideas, analyse options, evaluate alternatives, etc.  Typically, a meeting facilitator assists the group.

The group members can either discuss verbally or use computers to type ideas and information, which are then shared with all other group members via the network.  For large groups where only one person can speak at a time, typing ideas is faster than talking.  Everyone has the same opportunity to contribute and ideas can be collected much faster.  In addition, GSS enables users to make anonymous comments.  Without anonymity, certain participants may withhold ideas because they fear their ideas may not be well received.

The system also provides tools to support voting and ranking of alternatives, so that more structured decision-making process can be used.

Just like in document-based GroupWare, vendors use the Web browser as their client software.  So, almost anyone can access GroupWare Server.
Note. Discussion groups, document-based GroupWare and GSS all focus on the transmission of text and graphical images.

Information Superhighway. 

A term coined by U.S Clinton administration referring to advanced information infrastructure accessible to individuals, groups and firms.

In general, the Information superhighway can be defined as;

· A facility that provides a global electronic data interchange between computer users at a higher rate of message exchange, and at cheaper costs.  E.g., the Internet that allows researchers, businesses, and electronic media to exchange information.
· An Information Communication Technology (ICT) network, which delivers all kinds of electronic services – audio, video, text, and data to households and businesses.

The communication services on the superhighway can be one-to-one way (Telephones, e-mail, fax, etc); one-to-many (Broadcasting, interactive TV, video conferencing, etc), many-to-many (typified by bulletin boards and forums on the Internet).

Origin.
Information superhighway is a mass technology project aimed at creating a National Information Infrastructure (NII) in the U.S.

The concept emerged as the brainchild (idea) of U.S vice president Al Gore.   It is an alliance between the Federal government and a no. of industries.

The Information superhighway describes networks of Optic fiber and Coaxial cable linked by sophisticated switches that can deliver voice, data, image, text, and video signals all in the same digital language.

In the U.S, it has been proclaimed (declared) as the foundation for a national transformation to an information-based society, and a key element in the national efforts to sustain leadership in the world economy.

Governments and industries are developing a new method of competition, which will enable telecommunications, cable television, computer hardware and software companies, and entertainment corporations to work together to create and operate information superhighways.  These activities will finally result into a wide range of electronic services including electronic Shopping malls, collaborate electronic Education and distance learning, electronic Libraries, Multimedia information, messaging, and entertainment. 
Web casting.

Web casting (or “Push technology”) is a special application of the Web that has the potential to dramatically change the way we use the Web /Internet.

With Web casting, the user signs up for a type of information on a set of channels.  Regularly (minutes, hours, days), the user browser contacts the Web server providing these channels to see if they have been updated.  If so, the browser will load the information, and if required by the user, will automatically display the information on the user screen. 

Web casting changes the nature of the Web from one in which the user searches for information (a “pull” environment) into an environment in which the user accepts whatever information is on the Webcast Server (a “push” environment).   This is called the “Push” because the user does not request specific information, but rather permits the Web server to “push” the information when it becomes available.

The Web has been likened to a library because users move form site to site and page to page just like they move from shelf to shelf and book to book in a library.

Web casting is more like TV because the content and time of delivery is selected using the Web caster, the user only chooses the channels.

Web casting can be used for news (e.g., CNN) or financial reports (e.g., Stock market quotations), Corporate announcement, and as a replacement for broadcast e-mail.  It even has the potential to provide automatic updates to software packages.

Importance of services provided on the Internet.

The services offered by the Internet can be used as important tools in various ways:

1). As a research tool:
To learn about new developments or products, competitors, market news and customer opinions.
2). As an advertising / trading tool:
To help in selling goods or delivering information through the Web pages to customers on a 24-hour basis.

3). As a communication tool:
To support communication with customers, suppliers or staff through Electronic mail (e-mail).
4). As an Entertainment channel:
Most of the Games, Movies, and Television theme songs are available for free on the Internet.
In addition, you can have live, interactive conversations with people around the world including celebrities.
Users of the Internet.

Considering the facilities & the various tools offered, the Internet has attracted among others the following users;

· Researchers can get information.

· Writers and Scientists use the Internet to compile, compare and analyse their work.

· Individuals use the Internet for their work or to communicate with each other.

· People with the same interests can share ideas.
· Large organizations use the Internet to communicate with each other, and also to keep in touch with subordinate (subsidiary) companies or their suppliers.

· Students can communicate and gather information.
· Business people can advertise, communicate and sell their goods.

· Sales people use the Internet to keep in touch with their home offices.

· Buyers can do their shopping online.

Exercise (a).
1. (a). What do you understand by the term Internet?

(b). What are the other names of the Internet?
2. Describe the Functions of the Internet.

3. List 6 services that are offered on the Internet.
4. Identify 6 categories of people who can benefit through the use of the Internet.
Exercise (b).

1. Define the Internet.

2. Briefly describe six services offered by the Internet.

3. Discuss the growth of Internet in recent days.

4. Explain the importance of Information superhighway (Internet).
5. Write short notes on the following:

(a). E-commerce.

(b). Webcasting.

(c). Telnet.

(d). Information Superhighway.

CONNECTING (LOGGING ON) TO THE INTERNET.

Log On -To identify yourself & gain access to a computer.  To log on, type a user name & a password.

Facilities Needed.

To use the Internet, you must have access to it.  In order to get connected to the Internet and access the World wide Web, you will require the following facilities:
1). A Computer.

The computer to be used must have the following desirable elements;

(i). A Fast processor, e.g., Pentium 1 & above - to quickly access and download information & programs from the Internet.
(ii). RAM memory of 32 MB & Above.

(iii). Hard disk capacity of at least 400 MB.

(iv). A high-quality Colour Screen – to enable you view the various graphics and images.

(v). Free disk space on which to download the information or programs from the Internet.

2). Web Browsers.
Web browsers are application programs that are used to retrieve Web pages from the Internet onto your Personal Computer.
One of the most popular Web browsers is Internet Explorer from Microsoft.

Each Web page in the World Wide Web is based on an HTML (HyperText Mark Language) file.  A Web browser decodes the information in an HTML file and displays a Web page on your computer screen according to its instructions.  This process is called Downloading.
· Downloading is the process of copying files from one computer to another by using a Modem or a network connection.  You can also download files from the Web to your hard disk.
· HTML (Hypertext Markup Language) -The language used to create Web pages.  To view HTML documents, use Web browsing Software.

3). Telephone lines.

4). Modem (Modulator/Demodulator).
On the Internet, computers exchange information through Telephone lines.  Therefore, to use the Internet, you need a Modem & a Telephone line.

A Modem is a device that enables you to connect to the Internet, and access information.  
As a Transmitting modem, it translates computer information (which is in digital form) into analogue form (the form that can transmit over telephone lines).  This process is called Modulation.
As a Receiving modem, it translates the information back into digital form (a form that your computer can understand); a process called Demodulation.
The Modem must be fast.  This helps to reduce the amount of time spent waiting for Web pages, files, or messages from the Internet.

Modem speeds are expressed in Bits per second (bps).  The typical speeds are 9,600 bps, 4.4 Kbps (Kilobits per second), 28.8 Kbps, 56 Kbps, etc.
5). Internet Service Provider (ISP).
When connecting to the Internet using a modem, you need to sign up with an Internet Service Provider (ISP).
· Internet Service Provider (ISP) is a commercial organization (or a company) that provides Internet connections, along with a set of support services usually for a fee.  It maintains a Server that is directly connected to the Internet. 

· Internet Service Provider - A company or organization that provides Internet Access, usually for a fee.  To connect to your ISP, use a modem.

Most people and organizations connect to the Internet over a Telephone line through an ISP.  However, some larger businesses and institutions (such as universities) have their own Internet connections.

An ISP usually has a no. of Host computers.  These host computers usually provide space for the storage of user’s electronic mail messages, storage of user’s Web sites and a set of related facilities such as, advice, support software and appropriate security.
Examples of the local ISPs include; 
· Africa Online, Kenya Web, ISP Kenya, Swift Kenya, and Inter-Connect.

Connecting to an ISP involves calling the provider and setting up a PPP account.  When you open an account with an ISP, you will be provided with a User name and a Password.

(i). Username – Every time you get connected, you require a name to identify yourself on the Internet.
(ii). Password – This is needed for security purposes.  It ensures that your Internet account is secure.

Note. ISPs charge for the services rendered.

6). Website.

This is an area in the Internet where information of a particular organization is kept.  The Website must be updated on daily basis.
Content Provider - A business that uses the Internet to supply you with information such as news, weather, business reports & entertainment.

ACCESSING THE INTERNET.
There are 3 common ways in which an individual user can access the Internet:

(a). Through a connection already setup through the computer in your organization.  Typically, the service is accessed in a similar way to other services on a LAN.

(b). Through paying for an account with an Internet Service Provider (ISP).

In order to access an ISP directly, the user will need a Personal Computer, a Modem, a Telephone line & a suitable software in order to connect to the service.  Most ISPs give help and advice on how to connect.

(c). Through a Bulletin Board Service (BBS), e.g. CompuServe.  BBS are commercially run information providers, each with its own information services and normally offering access to Internet services.

The BBS companies normally sell some form of start-up package.

Setting up an Internet account.

Purpose.

· To be able to gain access to the facilities that are offered on the Internet, the user needs to log on.  To log on, use Dial-Up to connect to the Internet, and then use a Web browser like Internet Explorer to load Web pages.
There are several ways to start Internet Explorer;

Method 1.

1. Double-click the Internet Explorer icon on the desktop.

Method 2.

1. On the taskbar, click Start, point to Programs, then click Internet Explorer.

You may be required to make a connection through your ISP in order to log on to the Internet.  To do this, a Dial-up Connection dialog box is displayed.
2. Click in the User name box, and type a user name, for instance ‘Iat’.
3. Type in your password in the Password box, and then select the Save password checkbox.

The password appears in asterisk format (***) for added privacy and security.

4. Click the Connect button to access the Internet.
The Internet Connection wizard creates an Internet connection for you, and then displays a list of Internet Service Providers (ISPs) and information about their services. 
To sign up for a new account, click an ISP in the list.

Wizard - A tool that walks you through the steps of a complex task.

Selecting options in the Internet Connection Wizard.

If you are connecting to the Internet using a modem & an Internet Service Provider (ISP), your ISP will supply most of the information needed.  You will also need to provide the following information.

Information




Needed for.

The ISP you want to use


choosing an ISP

Your address & billing information

payment for your ISP account

Note. You may be prompted to restart your computer during the Internet connection process; save and close any open documents before you proceed.

5. After successfully logging on, the Internet Explorer displays the “Home page” and a Connection Indicator icon on the taskbar to indicate that you are online.

Method 3. To open Internet Explorer from Outlook Express.

1. On the Help menu, point to Microsoft on the Web, then click the Web option you want. 

E.g., click Search the Web to look for a Web site, a person, a company, or an organization. 

 – Or- 

Click Best of the Web to open the MSN.COM page that lists some of the best sites on the Web. 

Online Service - An Internet service that provides a wide range of content to its subscribers including Internet Access.

Parts of the Microsoft Internet Explorer screen.

1). Title bar.
2). Menu bar.

3). Address Bar.  It contains the Address box in which you type an address to open the file you want.  The Address Bar provides a method of opening files that are on the Internet or your computer.  

4). Current page, with Links.
5). Scroll bars.

6). Status bar.

7). Standard toolbar; with buttons such as, Back, Forward, Stop, Refresh, Home, Search, Favorites, History, Mail, Print, Discuss.

You can use the toolbar buttons in the Internet Explorer to move between Web pages, to search the Internet or to refresh the content of Web pages.

Button 



description.

Forward



moves to the next Web page.

Back



moves to a previously viewed Web page.

Home



jumps to your home page.

History



displays a list of recently visited sites.

Favorites
displays a list of Web pages that you have selected as your favorites.

Refresh
updates the contents of a currently displayed Web page or window.

Search



opens a Web page that lists the available search engines.

Edit
opens FrontPage Express or Windows Notepad so you can edit a Web page.

Print



prints a Web page.

Stop



stops the downloading of a Web page.

Mail



opens Outlook Express or Internet News.

Viewing connection information.

Purpose.

· When you register with an ISP, you acquire an Internet account with them and from time to time, you may want to view connection information such as, how long you have been online, the speed of connection & the activities done during the online session.

1. Right-click the Connection Indicator icon on the Taskbar.

2. From the shortcut menu that appears, click Status.

The Connected to <Africa Online> dialog box appears:

Some of the useful information displayed on this window includes:

· The speed at which you are connected, e.g. 26,400 bits per second (bps).

· The duration you have been online, e.g., 2 minutes, 50 seconds.

· The Transfer rate, in case you are downloading files from the Internet.

3. Click OK, after viewing the details.

Customizing the Web browser.

Purpose.

· Moving from site to site can be slow if the ISP or Internet lines are busy, if the Host server (the server storing the site you are trying to access) is busy, or if you are using a slow modem.

If a site contains graphics (or other multimedia content like video, audio, etc) you can prevent the graphics from downloading so as to speed up browsing.

1. On the Tools menu, select Internet Options….
2. Click the Advanced tab, then scroll down to the Multimedia section.
3. Deselect the options or content that you want turned off, e.g., Show Pictures, play Animations, or Play Videos, then click OK.
Multimedia – A technology that combines data/text, voices/sounds, graphics, pictures, videos and images into one complete system.  Multimedia uses Optical disk, e.g., CD-ROM to stock all the above in one media.  Multimedia can be used in training.

Logging out from the Internet.

Purpose.

· As long as you are connected to the Internet, you continue to incur Telephone and account usage charges.  This can prove to be expensive in the long run.  

It is recommended that you disconnect or log out from the Internet soon after you have finished with a session.  This is to avoid incurring extra or unnecessary charges.

1. Right-click the Connection Indicator icon on the Taskbar.

2. From the shortcut menu that appears, click Disconnect and you will automatically be logged out.

When you log out, the Connection Indicator icon is disabled.  
Note. Some browsers or ISPs automatically disconnect you from the Internet when there is no activity between the user and ISP for a period of about 5 – 10 minutes.

Understanding the World Wide Web.

Purpose.

· To understand some of the Internet terminologies like Web pages, Web sites, Web browsers, URLs and Home page.

The World Wide Web (www).

The World Wide Web is also known as the Web, WWW or W3.  
· The Web is an Internet application (software) that uses the Internet as its network.

· World Wide Web is the graphical, multimedia portion of the Internet.  

· The WWW is a collection of hyperlinked Web pages published on the Internet.  
· The World Wide Web is a global (an international) system of connected Web pages containing information such as, text, pictures, sound and video.  The WWW is hypertext based (i.e., it is able to access text & graphical data formatted for easy search, retrieval and display).

The Web is a part of the Internet.  It is comprised of millions of Web pages.  This huge collection of documents is stored on computers, called Hosts, around the world.  
The documents may contain text, pictures, sound, small programs or forms to be completed by a user.  

To view files on the Web, you need Web browsing Software.   This software can be used to view different locations on the Web or to explore the Web pages.  
Web pages.
· Web pages are documents published by organizations and individuals who are interested in putting themselves on the Web.  Web pages can include text, pictures, sound and video.

· Web page is a location on the WWW, usually a Web site.
The Web pages can also be found on company Intranets.

Intranets and Extranets.

What is an Intranet?

· An Intranet is an internal corporate network used in organizations to enable the sharing of documents among coworkers.  It supports users inside one organization (usually on a LAN).
· Intranet - A private network within an organization. It can connect all types of computers within an organization.
Intranet has a private Web Server, which can be made available to the entire organization, individual department or to specific departmental workgroups.

An Intranet uses the infrastructure and standards of the Internet and can be connected to the Internet.
Note. Intranet applications are usually combined with the normal Web application of other organizations, but are hidden from those outside the organization.
Extranet:
An Extranet works in much the same manner as an Intranet, but provides information to selected users outside the organization.  

E.g., a certain university can have an Internet library containing millions of articles, but only make it available to staff and students at colleges and universities within the country.
To access the library, you must provide a password when you connect to the Internet site.

Home Page.
· Home page is the Web page loaded when Internet Explorer is first started, i.e., when you access the Web.
E.g., the Internet address of the Windows home page is http://www.Microsoft.com /Windows
· Home page can also the first page of a company or an individual’s Website on the Web.
Those who offer information through the Web must first establish a Home page – a www text and graphical screen that welcomes the user and explains the organization that has established the page.
· Home page – is the introductory page of a Web site.  The home page contains links to other pages in the site.

Notes. 
· You can set any Web page as your Home page.

· Do not confuse your home page with the home page of the Websites you visit.  Your home page is set through Internet Explorer.  The home page of a Website is the introductory page for the site.

If you click a hyperlink such as Home on a Web page, you will jump to the home page of the Website, not yours.  To access your home page, click the Home button on the Explorer toolbar.

Web Site.
· A collection of Web pages belonging to an organization or individual.  These organizations or individuals maintain the Website.
· Web site - A group of related Web pages.

· A Web site is a screen or a collection of screens that provide information in text or graphical form that can be viewed by Internet users by activating the appropriate icon or commands.

Web Browsers (Web browsing software).

A Web browser is a program that lets the user browse through information on (or surf) the Web.  
Information on the Web is structured into pages.  Each page has a specific address that is used to locate and access information on that page.
A WWW browser program enables the user to either search for data by name or by specifying locations known as Uniform Resource Location (URL).

The two common Web browsers are:

· Internet Explorer from Microsoft.
· Navigator from Netscape.

Browsing the Web.

This is also known as Navigating or ‘Surfing’ the Web.
· To Browse is to navigate the Internet or the contents of your computer.

· Browsing can also be defined as moving around and between Web pages.  
Using a Web browsing software you can read documents, listen to music, watch videos, make purchases, participate in surveys, advertise products, do research, share interests and download files on the Web.

EXPLORING / BROWSING THE INTERNET. 

Use the Internet Explorer on your Windows desktop to browse the Web. 

There are several ways in which you can browse the Web pages or “surf the net”.
(a). When viewing a Web page, you can navigate the Internet by clicking Links, Underlined text or special features that cause you to jump to another Web page.

Hyperlinks.

A Hyperlink is a coloured or underlined text or a graphic that you click to ‘jump’ from one location to another.  The hyperlinks enable the user to ‘jump’ to another file, or to another location in the same file.

All Web pages have hyperlinks.  These links:
(i). Connect one part of a Web page to another part of the same Web page.  This is useful if the Web page is large.
(ii). Connect one Web page to another Website somewhere on the Web.

(iii). Connect a page to a file, such as a sound clip, video, a Spreadsheet or a Word document.

The links can connect to objects stored anywhere on the Internet.  
Hypertext links are indicated by underlined text highlighted usually in blue.  Hyperlinks can also be represented by buttons, graphics or pictures.

To find hyperlinks on a page, move your mouse pointer over the page and where there is a hyperlink, the mouse pointer will change into a hand with a pointing finger.  When you click a link, another Web page appears.

As you browse the Web, Internet Explorer stores the sites and pages that you visit.  Usually, the hyperlinks you previously selected are colored differently.  Internet Explorer does this to remind you that you have already visited the page identified by this link.
(b). You can also use the Standard toolbar buttons in the Internet Explorer to move between Web pages, or to search the Internet.
History.

Internet Explorer remembers the Websites and Web pages that you have visited.  It keeps record of each Web page as it is downloaded.  This is the History feature.

You can therefore, easily return to the page you have visited.  To redisplay the page you have just left, click on the Back button.  To move to the next page (available only if you have moved back), click the Forward button.

Web Hosting.

A World Wide Web Server is a computer with programs that answer requests for documents from Clients (browsers) over the Internet.  Files containing Web sites are placed on these servers.  
A Host computer is any computer connected to the Internet and stores information that has been made available to the Web.
ISPs also use host computers to store user’s electronic mail messages, Web sites and other related facilities such as, support software and appropriate security.
Web Address (Uniform Resource Locator – URL).

An Address is the location of a file.   
Each Web page in the world has a unique Internet address or location.  Internet addresses are also called the Uniform Resource Locator (URL).  E.g., the general URL for Microsoft is http://www.Microsoft.com./ 
You can use addresses to find files on the Internet & your computer.  You can instantly display any Web page if you know its URL.  E.g., http://www.compaq.com.    
AutoComplete - A feature in the Address Bar.  When you begin typing a previously used address, this feature finishes it as you type.

How the Web Works.
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Each Client computer needs an application software package called a Web browser, such as Navigator, Internet Explorer.  

Each Server on the network needs an application software package called a Web Server.  There are many different Web servers, such as those produced by Netscape, Microsoft and Apache.

In order to get a page from the Web, the user must type the Uniform Resource Locator (URL) for the desired page, or click on a link that provides the URL.  The URL specifies the Internet address of the Web Server, the directory and the name of the specific page required.  If no directory or page is specified, the Web server will display whatever page has been defined as its Home page.  If no server name is specified, the Web browser will assume that the address is on the same server and directory as the last request.

In order for the Web server to understand requests from the Web browser, they must use the same standard protocol.  If there was no standard, then each Web browser would use a different way to request pages.  This means that, it would be impossible for a Web browser from Netscape to communicate with a Web server from Microsoft.

The standard protocol for communication between a Web browser and a Web server is the HyperText Transfer Protocol (HTTP).  An HTTP request for a Web browser to a Web server has 3 parts, but only the 1st part is required, the other two are optional.

· The Request Line, which starts with a command (e.g., GET), provides the URL, and ends with HTTP version number that the browser understands.

· The Request Header, which contains a variety of optional information such as the Web browser being used (e.g., Internet Explorer), the date, the User ID and Password for using the Web pages as password protected.

· The Request Body, which contains information sent to the Server, such as information from a firm.

Note.  Every Web user must provide the Internet address of the receiving computer, otherwise, the server would not know where to send the requested page.  

Some browsers also provide the requestor’s e-mail addresses as well.  Most Web servers keep a record of Internet addresses of all the requests (and the e-mail address, if provided by the browser).  Some companies use this information to make a follow up with prospective customers.

An HTTP response for a Web server to a Web browser also has 3 parts, but only the last part is required, the first two are optional.

· The Response Status, which contains the HTTP version number the server has used as status code (e.g., 200 means ‘OK’, 404 means ‘Page not found’), and reason phrase (i.e., a text description of the status code).

· The Response Header, which contains a variety of optional information such as the Web server being used, the date, the exact URL of the page in the response body, and the format of the body (e.g., HTML).

· The Response Body, which is the Web page itself.

Internet Addresses.

Internet addresses are strictly regulated, otherwise, someone could add a computer to the Internet that had the same address as another computer.

Each address has 2 parts; The computer name and its domain.  

The Domain is the specific part of the Internet to which the computer is connected (e.g., Canada, Australia, etc).  

The general format of an Internet address is therefore: computer.domain.  Some computer names have several parts separated by periods.  For example, the main university Web server of an imaginary University like Yairobi can be www.Yairobi.edu, while the college of Humanities and Social Sciences server can be www.chss.Yairobi.edu. 

Each domain has an address board that assigns address for its domain.  The boards ensure that there are no duplicates.

Finding Web pages (information) on the Web.

There are 3 ways you can use to find interesting and useful Web pages on the Web;

1). You could get the Web address from an advertisement.

Many businesses include their Web addresses in their Television and Print advertisements.

2). You click a link that will enable you jump from one page to another.

Many industries or organizations, magazines and topic experts maintain pages that provide links from page to page.

3). Use of Search Engines.

Search Engines / Search Services.

· A Search engine is software that helps in locating information in the Web.

· Search engine is a tool that searches the Web for information that you want to find.  
Purpose.

· If you want to get some information concerning an area or subject of interest over the Web but you do not know where to find it, you can use a Search engine to locate sites that contain the information.

· Locate particular information in a Website, e.g., if you wish to read the Sports news you can load a Web site like http://www.cnn.com/, and then use a search engine within that site to locate information on Sports.

The following are the various search engines:

1). Yahoo – www.Yahoo.com. 

2). AltaVista – www.altavista.digital.com. 

3). Excite – www.excite.com.  

4). Meta Crawler – www.metacrawler.com.

5). Infoseek.

6). Lycos.

These search engines offer different kinds of searching capabilities.  However, they differ in the way they organize information in response to your request.

Yahoo focuses on the largest & most important Websites and organizes them in a directory format.  Small and little known Websites are excluded.  Therefore, if you are looking for the address of a well-known company or product or a popular topic, Yahoo is probably the easiest way to find it.

Alta Vista is the broadest of all.  It lists almost everything it can find.  It is probably the best choice if you are looking for an unclear topic or a very specific combination of topics or words (e.g., to find a famous quote).

The major disadvantage of Alta Vista is that, you may have to look through dozens of sites before you find the ones you want.  In addition, Alta Vista does not provide some help in focusing your search.

Excite is easier to use in that, it uses advanced special intelligence techniques to help you search those pages that best match your interest.  E.g., after looking at the result of a search, you can tell Excite to find more pages that are similar to a specific page it has found.  Excite will then search again and present those pages first.  In this case, Excite refines the search based on the characterization of the page you have selected.

Meta Crawler provides the best search facilities.  It does not search the Web and provide a list of what it finds.  Instead, whenever you enter a search request, it simultaneously sends that request to several search engines (including Yahoo & Alta Vista), then combines, and organizes the information it receives from all the search engines into one display.

How Search Engines find Web pages.

Hundreds of thousands of new Web pages are created each day.

There are 2 ways that search engines use to locate Web pages:
· Use of Spiders / Robots.

· Through Submissions.

(a). Spiders.
Search Engines normally use software spiders to explore the Web.  The Spiders are usually automated robots that travel around the Web looking for new pages, and creating links to them.

These spiders methodically search all the pages on the Websites they can find and report back their discoveries.  The search engine builds an index to these pages based on the words they contain.  When you connect to a search engine, and type a few words describing what you want, the Search engine will search its index for these keywords and provide you with a list of pages that contain them.

(b). Submissions.

These are derived from people who have created new Web pages and then submit information about the pages they have created.

1. Select a search engine, e.g., Yahoo, and type its address in the Address box, i.e., http://www.yahoo.com/. 

Once the search engine home page appears, type a keyword or phrase in the Search box, e.g., Kenya, then click the Search button.

Note.  The steps may vary depending on the search engine you are using.

2. When the search is completed, a list of sites that contain the keyword or phrase you are looking for is displayed.  Select a site whose description comes closest to the information you desire and click on its link.

3. If there are many sites, an option that allows you to view the next 10 or so matches is displayed.  Click on this if necessary to view the next set of links.

If there are too many matches, you may want to use an additional keyword to narrow down the search.  E.g., to find the sites that contain information about the economy in Kenya, in the Search box, type phrase “Kenya AND Economy”.

4. Click the Search button.

5. From the search results, select the links that may help you get the information you require.  

Locate information within a Website.

Once you access a Website, you can search for specific text or information on that site or page.  

Unlike search engines like Yahoo, Infoseek, Lycos, Web Crawler, and Excite that present you with the URLs or links of sites that hold information you are looking for, search engines within a Web page locate information within that Web page.

1. Load the Web page to browse.  E.g., let’s use a Website: http://www.carleton.ca. 

2. Click in the Search box, and type a keyword(s), e.g., International AND Student.

Note. When typing in a keyword, you can use logical words or operators like AND (when you want to display results that meet both criteria) and OR (when you want to display results that meet one of the two criteria).

3. Click the Search button, to begin the search.

4. From the Search Results screen, click on a link that is closest to your requirements.

To open a favorite Web site from the Start menu.

1. Click the Start button, point to Favorites, and then click the Web page you want. 

To search the Web from the Start menu.

1. Click the Start button, point to Find, then click On the Internet. 

To use the Run command to open a Web page.

1. Click Start, click Run, and then type the Internet address you want. 

If the page you are opening is one you've viewed before, the AutoComplete feature can complete the address for you.

To find pages you've recently visited.

To find Web sites and pages you've viewed in the last few days, hours, or minutes.

1. On the toolbar, click the History button. 

The History bar appears, containing links for Web sites and pages visited in previous days and weeks.

2. In the History bar, click a week or day, click a Web site folder to display individual pages, and then click the page icon to display the Web page. 

Notes.
· To return to the last page you viewed, click the Back button on the toolbar. 

· To view one of the last nine pages you visited in this session, click the arrow to the side of the Back or Forward button, and then click the page you want from the list. 

To enter Web information more easily.

The AutoComplete feature saves previous entries you have made for Web addresses, forms, and passwords. 
When you type information in one of these fields, AutoComplete suggests possible matches. 

1. When typing an information in the Address bar, and the AutoComplete feature suggests what you want to enter in that field, click the suggestion.  If not, continue typing. 

Setting or changing a Home Page.
Home page is the page that is displayed every time you start Internet Explorer. 

Note.  Make sure it is a page that you want to view frequently, or make it one that you can customize to get quick access to all the information you want, such as the Msn.com home page. 

Purpose.

· To enable the user to choose or specify a page that will provide a good starting point for exploring the Web.

The Home page will appear each time the user accesses the Web.

1. Go to the page you want set as your Home page.

2. On the Tools menu, click Internet Options....
The Internet Options dialog box appears.
3. Click the General tab.

4. Under the Home Page section, type the address of the new home page in the Address box.  Alternatively, click Use Current to make the current Website the home page.
5. Click the OK button.
Tips. 

· To restore your original home page, click Use Default. 

· You can return to your home page anytime by clicking the Home button.

Exercise.

1. Mention at least 4 facilities that are needed to connect to the Internet.
2. How can you establish the time you have been online in a session?

3. In a step-by-step format, illustrate how you can log out of the Internet.

4. Define the following terms:

(a). Intranet.

(b). Extranet.

(c). Worldwide Web.

5. (i). What is a Web site?

(ii). Give the advantages and disadvantages of a Web site.

6. Give 2 examples of Web Browsers.

7. Explain the term ‘Host computer’.

8. Define the word ‘History’ with reference to a Web browser.
9. (a). What is a Search engine?

(b). Give examples of Search engines.

10. How does the Web work?  Explain with the help of a diagram.

11. Describe the procedure of finding information on the Web.

Downloading Web pages and programs from the Internet.

Purpose.

· To enable the user to view Web pages without being connected to the Internet.
· To be able to browse a site in a location that does not provide any network access.

· In order to free your telephone lines.

Downloading a Web page.

1. Load the Web page you want to download, e.g., http://www.nationaudio.com. 
2. Access all the links that you would like to read offline.  Make sure that the whole Web page is fully loaded before moving to the next one.

3. On the Favorites menu, click Add to Favorites.
4. Select the option Yes, notify me of updates and download the page for offline viewing.

5. Click OK, and then Logoff.

Downloading a program.

· Programmers and software houses like Microsoft usually develop programs and may decide to send a test copy to their existing clients or to publish it on the Internet for interested users to test it for a specified period of time.
To test such software, a user will have to download the program onto the hard disk.  A user can also download a movie clip or games, etc, and view it offline to save on costs.
1. Locate a site from which you wish to download a program, e.g., http://softwarenow.iboost.com. 

2. Select the category of programs you want to download, e.g., Games.

3. Select a game category, e.g., Racing Games.

4. Select a game you want to download.

Note. The window lists the properties of the program, e.g., version, file size.  Ensure that you understand the licence agreement, i.e., whether the program is freeware or shareware.

Freeware is a program that is absolutely free, while Shareware program is available for a limited period of time.

5. To download the program, click on the download link, e.g., Download Cars & Brix.
6. From the File Download dialog box, select Save this program to disk option, then click OK.
7. In the Save As dialog box, select the folder in which you wish to store the downloaded program, then click Save.

Once the program is loaded, you can access the folder it was saved in and load it without being connected to the Internet.
Saving pictures or text from a Web page.

Purpose.
· You can save information for future reference or in order to share with other people.  You can save the entire Web page or any part of it: text, graphics, or links. 
· You can print Web pages for people who don’t have access to the Web or a computer. 

To copy information from a Web page into a document, 

1. Select the information you want to copy, on the Edit menu, click Copy.

To use a Web page image as desktop wallpaper.

1. Right-click the image on the Web page, then click Set as Wallpaper.

Saving information (a Web page) from the Internet to the Hard disk.

Purpose.

· When you come across a Web page you would want to read, but it is too long, you can save the Web page onto your hard disk so as to read it later on when you are off-line.  This helps in reducing the costs of browsing while online.  

1. Load the Web page you want to download. 
Make sure the Web page you want to save is completely transferred to the screen of your Web browser.

2. On the File menu, select Save As.

3. In the Save HTML Document dialog box that appears, select the drive & folder where you want to save the page in.

4. In the File name box, type a name for the page.

5. In the Save as type box, select a file type.

· To save all of the files needed to display this page, including graphics, frames, and style sheets, click Web Page, complete. This saves each file in its original format.

· To save just the current HTML page, click Web Page, HTML only. This will save the information on the Web page, but it does not save the graphics, sounds, or other files.

· To save just the text from the current Web page, click Text Only. This saves the information on the Web page in straight text format.

6. Click Save.  

The Explorer program automatically assigns the extension .htm to the file name.

To open a saved file.

· After saving a Web page, you may want to read and analyze the information at a later time.  
· You may also want to send the saved file to another person via e-mail as an attachment.

1. On the File menu, select Open.  This displays the Open dialog box.

2. Click on the Browse button in order to locate the folder where the file is stored.

3. Click the file, then choose Open.

Note.  When you save a file in a local disk, only the text on the page is shown.  The graphics in a site are displayed in graphics placeholders (which appear as small rectangles).

Graphics and Download time.

When designing Web pages, graphics have to be incorporated sensibly into the Web page.  

Although they are appealing to the eye, the more graphics you use on a Web page, the longer the Web browser will take to download the page.

File Formats.

The most common file formats found on the Internet are:

· Graphic Interchange Format (GIF), and

· Joint Photographic Experts Group (Jpeg).

Generally, GIFs are used for simple page design elements like lines, buttons and dividers, while JPEGs are mostly used for complex photographs and images.

Movie (video) files usually have the extension .avi, .mpg, or .mov, while Sound (audio) files have the extension .au, or .ra, or .ram, or .wav.

Printing Web pages.

Purpose.
· To obtain a hard copy of the information that you have researched on and collected, for the purposes of reviewing later or filing.
Change how a page looks when it prints.

Before printing a Web page, it is advisable to check the settings in the Page Setup dialog box.  
This will ensure that the right Paper size, Margins and Orientation of the page are set correctly.  You can also add headers and footers to a Web page.
1. On the File menu, click Page Setup. 

2. In the Margins boxes, type the margin measurements (in inches). 

3. In the Orientation area, click either Portrait or Landscape to specify whether you want the page printed vertically or horizontally. 

4. In the Header and Footer boxes, specify the information to be printed, then click OK. 

Printing the Web page.

1. On the File menu, click Print to display the Print dialog box.
2. Set the printing options you want, then click OK. 

Exercise.

1. What are the benefits of saving information from the Internet to your hard disk?

2. List the type of files that can be downloaded from a Website.

3. In which dialog box would one enter a footer and header of a Web page to be printed.

4. Graphic objects are visible upon opening of saved Web pages.  True/False? Explain.
5. Define the following terms with respect to the Internet:

(i). Website.

(ii). Upload.

(iii). Access Provider.







(6 marks).

Creating a Bookmark.

Purpose.

· When you browse the Web, you may come across sites that you want to visit regularly.  
Examples of such sites include; news sites like CNN or BBC.  You can decide to ‘bookmark’ the Web page.
The Bookmark feature (also known as a Hotlist or Favorites feature) allows you to store the addresses of Web pages that you frequently visit.  Hence, you do not have to constantly retype your favourite Web page addresses.  When you want to visit the site, simply select the bookmark from a list.
1. Open the Website that you want to create a shortcut to.  E.g., http://www.cnn.com. 

2. On the Favorites menu, choose Add to Favorites.
The Add to Favorites dialog box appears.  The name of the site you are in appears on the Name box.

3. Under Create in: click the folder you want to add the site to, e.g., Links, then click OK.
This will add the title of the Web page in the Favorites list.

To go to a site using a Bookmark.

1. On the menu bar, select Favorites.
2. Select the folder that holds the favorites item, e.g., Links.  

3. From the drop-down list, click CNN.com.
To delete a Bookmark.

1. On the menu bar, select Favorites.

2. Point to the item from the Favorites list, e.g., CNN.com.

3. Right-click the item, and then click Delete.
The Confirm File Delete dialog box appears.

4. Click Yes, to remove the item from the list.

Working Offline.

Connection to the Internet usually means that you are using telephone lines, and therefore incurring telephone charges and usage on your ISP account.

Offline - Not connected to a network or the Internet.

BROWSING THE WEB (INTERNET) OFFLINE.

Purpose.

· To enable the user to save on the time spent connected to the Internet, and hence reduce the general costs of being online.

1. Access the Web site that you want to browse offline.

2. Access all the links to download all the information you require.

Ensure that each Web page is downloaded completely before going to the next one.

3. On the Taskbar, right-click the Connection Indicator button, then choose Disconnect.

The Connection Indicator disappears from the Taskbar showing that you are now working offline.

After disconnecting the user can go ahead and read all the downloaded information.  The user can also “browse” through the site while offline provided all the pages and links are downloaded.

Note. Some services like Internet, Usenet, Newsroom, or Shopping will not be available when you are offline.  To use these services, you need to re-establish the connection.

Making Web pages available for offline viewing.

Offline Reading -To view a Web page without being connected to the Internet.

You can download the page to your hard disk, disconnect from a network or the Internet, and read the material later.

When you make a Web page available offline, you can read its content when your computer is not connected to the Internet. 

E.g., you can view Web pages on your Laptop computer when you don't have a network or Internet connection. 

1. On the Favorites menu, click Add to Favorites. 

2. Select the Make available offline checkbox. 

3. To specify a schedule for updating that page, and how much content to download, click Customize. 

4. Follow the instructions on your screen. 

Note. Before you go offline, make sure you update your pages.  To do this, click the Tools menu, then click Synchronize. 

To make an existing favorite item available offline.

1. On the Favorites menu, click Organize Favorites. 

2. Click the page you want to make available offline. 

3. Select the Make available offline checkbox. 

4. To specify a schedule for updating that page, and how much content to download, click Properties. 

Get Help with Internet Explorer.

Purpose.

· While working with Internet Explorer, you may sometimes need help on how to perform certain tasks or help on a particular topic of interest.
1. On the Help menu, select Contents and Index (or press F1).
The Internet Explorer Help window is displayed.

2. Click the Contents tab.
3. Click a book in the list, and then click a Help topic you want to look at.

The Help topic contents are displayed on the right-hand side of the Help window.

4. Read the help and click the hyperlinks (blue, underlined text) if you want to see help on related topics.
5. When you have finished, click the Close button to exit help.

Using the Index to get Help.

1. On the Help window, click the Index tab.

2. Type in the first few letters of the word or topic that you are looking for.

In the Index box, all the help topics are listed in alphabetical order.

3. Click the Display button to view the information about the topic selected.

Exercise.
1. What is a Bookmark?

Advantages of the Internet.

(i). One can download (copy) information from a Website.

(ii). The Internet has enabled the interlinking of people worldwide / globally.

(iii). It is convenient in the sense that you can access data 24 Hrs.

(iv). It is cheap, i.e., the operational cost that one may incur is low.

(v). It has brought in the technology of doing the following; E-learning, E-Agriculture, E-commerce, E-governance, etc.

(vi). Provides up-to-date information.

(vii). It doesn’t require a lot of training to browse.

(viii). It provides entertainment facilities.

(ix). Can be used for research.

(x). Brings harmony in the world, because people can communicate and exchange ideas.

(xi). The Internet can be accessed at any part of the world.

(xii). There is always a full backup provided by the Servers, hence no data loss.

(xiii). It’s a fast way of communicating. 

(xiv). It provides an easy way to use offers in Information and products.  

Internet provides information from almost all parts of the world that you need in order to make accurate and informed decisions.

You will get information you need from business to education, from sports to politics, from arts to eating out.  
Disadvantages of Internet.

(i). It’s a technology, which is fetched for (imposed/forced on) the Third world countries.

(ii). The cost of the Internet Service Provider is high.

(iii). It is leading to exposure of morally harmful shows such as Pornography.

(iv). It leads to spread of viruses.

(v). Has proved to be unreliable especially accessing information.

(vi). No copyright rules meant to protect the property of an organization.

ELECTRONIC MAIL (E-MAIL).
About e-mail.
Electronic mail (also known as e-mail) is one of the common services provided by the Internet.
· E-Mail is a worldwide system for sending & receiving electronic messages from one computer to another.
· E-Mail (Electronic mail) refers to electronic messages sent over the Internet or a network.  E-mail can contain both text & files.

With e-mail, users can create and send messages to one user, several users, or all the users on a distribution list.

Most e-mail software enable users to send text messages. In addition, users can attach files from Word processors, Spreadsheets, Reports, production data, etc, and then send them by e-mail. 
Most E-mail packages allow you to do the same things you do with regular paper mail.  You can file messages in electronic file cabinets, forward copies of messages to other users, send “carbon copies” of messages, and so on.  The E-mail packages also allow you to filter or organize messages by priority.  E.g., all messages from a particular user (e.g., your boss) could be given top priority, so that they always appear at the top of your list of messages.

However, E-mail is a much faster, economical & convenient way of sending messages to family, friends and colleagues than the paper mail (usually called “Snail mail”).  Messages can be sent or received 24-hrs a day.  With “Snail mail” a message or a letter is sent to the recipient through the Post office and takes days or weeks before reaching the destination.  
Components required.

For one to be able to communicate using e-mail, the following components are needed:
1). A Computer - where you will send or receive the e-mail messages.
2). An E-mail program.
Your computer must be installed with an e-mail program that lets you send, receive and manage your e-mail messages.  

Examples of E-mail programs; 
· Microsoft Outlook, Outlook Express, & Microsoft Exchange from Microsoft.
· Communicator from Netscape. 
· Lotus Notes.

· Eudora.
3). E-mail address of the sender & the address of the receiver.
4). An Internet Service Provider (ISP) - company who will deliver your message to the receiver.

Once you send a letter or a message, it travels from your computer through a Modem, which connects your computer to the Internet using the Telephone network.  The Mail passes through various computers, until it reaches the final destination.
How E-mail Works.

The figure below shows how an e-mail message can travel over a Wide Area Network (WAN) such as the Internet.

[image: image2.png]User Agent.

Mail Transfer Agent

Mail Transfer Agent

Clent Computer

User Agent

Clent Computer

ail Server
Mail Serve

User Agent

o

Client Computer

Frrery p——




Each Client computer in the Local Area Network (LAN) runs an e-mail software package called User Agent, e.g., Eudora, Lotus Notes, Outlook Express, Microsoft Outlook, etc.

The user writes the e-mail messages using one of the User Agents, which formats the message into 2 parts;

(i). The Header, which lists the source and destination e-mail addresses.

(ii). The Body, which is the message itself.

The User agent sends the message header & body to a Mail Server that runs a special application package called a Message Mail Transfer Agent.  The Message Mail Transfer Agent in the Mail Server reads the envelope & then sends the message through the network (possibly through dozens of Message Transfer Agents) until the message arrives at the Mail Server of the receiver.  

The Message Transfer Agent on this server then stores the message in the receiver’s mailbox on the server.

When the receiver accesses his/her e-mail, the User Agent on the receiver’s Client computer contacts the Message Transfer Agent on the Mail Server, and asks for the contents of the user’s mailbox.  The Message Transfer Agent sends the e-mail message to the client computer, which the user reads using the user agent.

E-MAIL STANDARDS.

Several standards have been developed to ensure the compatibility between different e-mail software packages.  

The 3 commonly used standards are:

1). Simple Mail Transfer Protocol (SMTP).

2). X-400.

3). Common Messaging Calls (CMC).

All the 3 e-mail standards work in the same basic fashion.  

Simple Mail Transfer Protocol (SMTP).

SMTP is the most commonly e-mail standard used on the Internet.

SMTP defines how Message Transfer Agents operate and how they format messages sent to them.  As the name suggests, SMTP is a simple standard that permits only the transfer of text messages.  Non-text files such as graphics or Word processing documents are not permitted.

However, several standards for non-text files have been developed that can operate together with SMTP.  They include; Multi-Purpose Internet Mail Extension (MIME), Unencoded & Bin Hex.

A different standard called Post Office Protocol (POP) defines how User agents operate and how messages to & from the Mail Transfer Agents are formatted.

POP is gradually being replaced by a newer standard called Internet Mail Access Protocol (IMAP).  

The main difference between POP & IMAP is that, before a user can read a mail message with a POP user agent; the e-mail message must be copied to the client’s hard disk and deleted from the mail server.  With IMAP, e-mail messages can remain stored on the mail server after they have been read.  Therefore, IMAP is beneficial to users who read their e-mail from many different computers (e.g., at home, in office & in computer labs), because all e-mail is stored on the server until it is deleted.

X-400

The X-400 e-mail standard was developed in 1984.  It is a set of seven (7) standards that define how e-mail is to be processed by the User agents and the Mail Transfer Agents.

Common Messaging Calls (CMC).

The CMC standard is a simpler version of the X-400 standard.  

It was developed in 1994.

It is more popular than X-400, because it is simple & it is also supported by a large no. of leading vendors/sellers.

File Transfer Protocol (FTP).

FTP enables you to send and receive files over the Internet.  FTP requires an application program on the client server and an application program on the FTP Server.  Many application packages use the FTP standard (e.g., WS-FTP).

Almost anyone can establish a FTP server, which permits anyone on the Internet to log in, send and receive files.

There are 2 types of FTP sites;

(i). Closed.

(ii). Anonymous.

Closed FTP site.

A Closed site requires users to have permission before they can connect and gain access to the files.  Access is granted after the user provides an Account name with a secret password.

For example, a Network Manager would write a Web page using software on his/her client computer and their user FTP to send it to a specific account on the Web Server.

Anonymous FTP site.

Anonymous is the most common type of an FTP site.  

It permits any Internet user to log in using the account of anonymous.

When using the anonymous FTP, you will still be asked for a password.  You can enter your Internet e-mail address as the password.

Many files and documents available via FTP have been compressed to reduce the amount of disk space they require.

Note.  If a file that you want has been compressed by a compression program that is not in your computer, you cannot access the file until you get the decompression program it used.

Using Lotus Notes.

One of the problems with e-mail is that, it lacks a structured way to support an ongoing discussion.  Each mail message is a separate item, unrelated to the other messages.  Usually, you can group and file e-mail messages into separate file folders, but it not possible to combine them.

Using Lotus Notes (a document database of text and graphics), documents with different sections can be organized into a hierarchical structure of sections, documents and folders.

Lotus Notes can be used as a computer Bulletin board to support ongoing discussions. Several topics and sub-topics can be created, and everyone or selected individuals in the organization can be given access.  

Lotus Notes can also be used to organize a discussion among certain people such as a Project team working to improve manufacturing quality.  It might reduce the amount of time the team spent in face-to-face meetings, because many of the issues might be discussed before the meeting actually starts.

Lotus Notes also could be used to replace standard Word processors in preparing reports.  Each team member could use Lotus Notes to write a portion of report, which could then be passed to other team members for editing or comments.

Lotus Notes can also automate certain document-based processes (called Workflow automation).  For example, insurance claims require people from several different parts of an Insurance company to work together to process the claim.  One person might handle the initial claim, which would then be passed to an Insurance adjuster to finish a report.  Another person would process the payment.  All this paperwork could be replaced if Lotus Notes were used to prepare and pass the documents from one person to another.

Note. Lotus Notes has the ability to replicate.  Replication is the automatic sharing of information among servers when information changes.  E.g., Lotus Notes servers can be set to replicate information they contain within any other Lotus Notes server on the network, so that a change to a document on the server will automatically be shared with all other servers that contain the same document.

Setting up (adding) an E-mail or News account.
To set up an e-mail account, use an e-mail program such as Outlook Express.  Outlook Express is a Web browsing software that can help you exchange e-mail messages with colleagues and friends on the Internet or join newsgroups to trade/share ideas and information.

You will need the following information from your Internet Service Provider (ISP) or Local Area Network (LAN) administrator:

· For e-mail accounts, you'll need to know;

· The type of Mail server you use (POP3, IMAP, or HTTP) 
· Your Account name and Password.

· Name of the incoming mail server and, 
· If you are using POP3 or IMAP, the name of an outgoing mail server. 

· For a news account, you'll need to know;

· The name of the news server you want to connect to and, if required, your account name and password. 

To add a mail or news account.

1. On the Start menu, point to Programs, then click Outlook Express.

2. On the Tools menu, click Accounts. 

3. In the Internet Accounts dialog box, click the Add button. 

4. Select either Mail or News to open the Internet Connection Wizard, and then follow the instructions to establish a connection with a mail or news server. 

Tips.
· After you set up your account, just double-click the Outlook Express icon on the desktop to begin sending and receiving e-mail.

· You can get a free mail account from Hotmail, which uses HTTP servers. 

E-mail addresses.

Each user has his own e-mail address (or mailbox) in form of computer storage space to receive messages.  The mailbox is accessed via a computer terminal within the system.  In addition, each user has a password to protect access to his/her own mailbox.

Messages are drawn to the user’s attention when they enter the system.

Components of an E-mail address.

An e-mail address consists of two parts separated by the @ symbol.  For example, if your e-mail address is Drg@tropicalheat.com: 
(i). The 1st part of the address to the left side of the @ symbol refers to the person’s identity or login name.  It is the name or identifier of the specific individual or organization, e.g., “drg”.
(ii). The 2nd part following the “@” symbol is the computer address.  It is usually made up of 2 to 3 sub-parts to further identify the individual, organization, ISP or a country.  In this case:

· “tropicalheat” identifies the business.

· “.com” is the extension, which identifies the type of the organization.

The table below shows some extensions and what they represent: -
	Extension 
	Represents

	.org
	A non-profit making organization

	.edu
	An educational institution or organization

	.com
	A commercial organization

	.net
	Network

	.mil
	Military

	.gov
	government


Sometimes, the name of the country is included in the e-mail address.  E.g., Skynews@sky.co.uk or Nation@africaonline.co.ke. 

In this case, “.co.uk” refers to a company in the United Kingdom, while “.co.ke” refers to a company in Kenya.

Examples of E-mail addresses;

Smith@CompuServe.com
Iat@Africaonline.co.ke
Were@Egerton.edu
Manager@Kenyapower.org
Bridge@arcc.or.ke
Tim@Yahoo.com

(free e-mail address)
Douglas@hotmail.com
(free e-mail address)
Exercise.

1. (a). What is E-mail?

(b). Give TWO examples of e-mail software.

(c). Give an example of an e-mail address.

2. Identify institutions whose e-mail addresses end with the following extensions:

(i). .org
______________________________________________________

(ii). .gov
______________________________________________________

(iii). .edu
______________________________________________________

(iv). .com______________________________________________________

(v). .net
______________________________________________________

(vi). .mil
______________________________________________________

3. Identify the parts of the following e-mail address:

iat@africaonline.co.ke 


 A         B           C    D

A _________________________________________________________________

B _________________________________________________________________
C _________________________________________________________________
D _________________________________________________________________
Reading E-mail Messages.
Purpose.

· Once an e-mail message that has been sent to you arrives at your computer, to read the contents you must open it using the program you have installed for sending e-mail, e.g., Microsoft Outlook or Outlook Express.
1. Open the e-mail program, e.g., Outlook Express from the Start menu or a shortcut on the desktop.
The Choose Profile dialog box appears to allow you to select your profile.

Note.  A User Profile is a group of settings that define how the e-mail program is set up for a particular user.  It also defines through the information services how a user can send, store, and receive messages.
2. Select your profile by clicking the down arrow on the Profile Name box, and then click OK.
Usually, all incoming messages are stored in the Inbox when you connect to Outlook Express.  The Inbox displays all the e-mail messages that you have received.
3. To open and read e-mail messages, click the Inbox icon either on the Outlook bar or on the Folders list, and then choose the message that you want to read.
· To view the message in the preview pane, click the message in the message list. 

· To open the message in a separate window, double-click the message in the message list. 

The lower grid of your screen will have the full message.  
4. When you have finished reading a message, you can close the window.  Choose Exit on the File menu.  This will take you back to the Outlook Express window.  If there are any e-mails in the Outlook that have not been sent, a message will appear prompting you to send the e-mail(s) at that particular time or you can send it later.

Tips

· After Outlook Express downloads your messages, you can click the Send/Recv button on the toolbar, to read messages either in a separate window or in the preview pane. 

· To view all the information about a message, such as when it was sent, click the File menu, and then click Properties. 
· As you read the items in your items in your Inbox, you can reply to, forward, or file them in other folders that you create.

· To save the message in your file system, click Save as and then select a format (mail, text or HTML) and location. 

Reply to E-mail Messages.

Purpose.

· If you have read a message, you may want to send a reply to the original sender.

· If the original message that you are replying to was also copied to a no. of other people, you may want to send a reply to all of them.
When replying to a mail message, you can choose to reply with or without the original message insertion.  The original message, sometimes referred to as the History, appears in the body of the message, and is used for reference purposes.  
Reply with the original message insertion.

1. Open the message you want to reply.

2. Click the Reply button in the Mail window.  The Reply message window appears containing the message you are replying to at the bottom.

3. Type the reply where the insertion point is.

4. When you have finished typing and editing the reply, click the Send button (if you are online) to send the message.

Note.  If you click the Send button while you are offline, the mail will be placed in the Outbox folder and will automatically be sent the moment you are online.
Reply without the original message insertion.

To remove the original message, select the text, and then press the DELETE key or set options in the Options dialog box. 

1. On the Tools menu, click Options.
2. Click the Reading tab.

3. Under When replying to a message box, click the down arrow, then select Do not include original message, then click OK.
4. Follow the procedure used to reply a message with the original message insertion.  
This time, the Reply message window will not contain the message you are replying to at the bottom.
Note.  After replying to an e-mail, the E-Mail icon will indicate a checkmark showing that the mail has been replied to.
Creating and sending an e-mail message.

Purpose.

· To communicate with another user who has an e-mail address.  This is cheaper than sending fax or using the telephone especially for long distance calls.
· It is also faster to send e-mail than to post a letter.  
E.g., to send a letter around the world using e-mail takes some few minutes as compared to the weeks ordinary mails take.
1. Start the Microsoft Outlook window.

2. On the toolbar, click the New Mail Message button. 

The message composition window is displayed.
3. In the To… and/or Cc… boxes, type the e-mail addresses of each recipient. 

· If you want to sent copies of the message to other people, type in their e-mail addresses in the Cc… box, separating the addresses with a semicolon (;).
· To add e-mail names from the Address Book, click the book icon in the New Message window next to To, Cc, and then select names.

· You can also send a Blind Carbon Copy (Bcc).  In this case, the recipients entered receive the message but their names are hidden from other recipients of the message.  To use the Bcc box, click the View menu, and then select Bcc field.
4. In the Subject box, type a message title. 

5. In the lower grid of the message composition window, type in the message that you want to send.

You can format the e-mail message using the formatting tools like, Bold, Font size, Underline, etc.

6. When you have finished typing the message, editing, and spell checking, click the Send button on the New Message toolbar. 

Notes.

· To save a draft of your message to work on later, click the File menu, then click Save. You can also click Save as to save a mail message in your file system in mail (.eml), text (.txt), or HTML (.htm) format. 

· A message that returns to the sender because it cannot reach its destination is referred to as a Bounced message.

Checking the spelling in mail messages.

Before sending a mail message, you can spell check it to correct any spelling mistakes in the mail.

Outlook Express uses the spelling checker provided with Microsoft Office 97 programs, such as Microsoft Word, Microsoft Excel, and Microsoft PowerPoint. 

1. In the New Message window, click the Spelling button on the toolbar, (or click the Tools menu, and then choose Spelling). 

2. The Spelling dialog box appears.  The misspelt words are highlighted and shown in the dialog box.  Choose the correct word by selecting it, and then click the Change button.
If the word or phrase is correct but is not in the dictionary, click Ignore.
3. Once spell checking of the mail is complete, and a dialog box appears, click OK.
Formatting e-mail message text.

To add special emphasis or structure to message text-such as bold, color, or bulleted lists, and also to add graphics and links to Web sites in your mail messages, use Hypertext Markup Language (HTML) - the standard language for formatting text for the Internet. 

To use HTML formatting on all outgoing messages.

· When you create messages using HTML formatting, only mail programs that support HTML can read the formatting. If the recipient's mail or newsreading program does not read HTML, the message is displayed as plain text with an HTML file attached.  The recipient can view the attached file by opening it in any Web browser. 

To send the message in HTML formatting;

1. In the main window, click the Tools menu, click Options, then click the Send tab. 

2. In the Mail Sending Format or News Sending Format sections, click HTML. 

To use HTML formatting on an individual message.

In an e-mail message window, make sure HTML formatting is turned on, i.e., Click the Format menu, then choose Rich Text (HTML). A black dot appears by the command when it is selected. 
To change the font, style, and size of text.

You can change the way the text looks for all your messages or you can make changes to selected text within a message.

To change the text style for all messages.

1. On the Tools menu, click Options. 

2. Click the Compose tab, then click the Font Settings button.

To format text within individual messages.

1. Select the text you want to format.  To change the font for an entire message, click the Edit menu, then click Select All. 

2. On the Formatting toolbar, click the buttons for the options you want. 

To format a paragraph.

1. Click anywhere in the paragraph, or select the text you want to format. 

2. Use either the Formatting toolbar or the commands on the Format menu to change the text. 

To
                                        Do this


Change the indentation of a paragraph
Click the Increase Indent or Decrease Indent button on the Formatting toolbar.

Add a horizontal line

Click where you want the line to appear, and then click the Insert Horizontal line button on the Formatting toolbar.

Format text written in Rich Text (HTML) mode
Click the Format menu, point to Style, and then choose an option.


To create a numbered or bulleted list.

1. In your message, click where you want the list to start. 

2. On the Format menu, point to Style, then click either Numbered List or Bulleted List. 

3. Type the first item in the list. When you press ENTER, another list entry is started on the next line. 

To end the list, press ENTER twice. 

Inserting items in a message.

To insert a Business card in all messages.

1. On the Tools menu, click Options, then select the Compose tab. 

2. In the Business Cards section, select the Mail or News check box, and then select a business card from the drop-down list. 

Notes.

· To change information in a business card, click the Edit button. 

· To add a business card or signature to an individual message, in a message window, click the Insert menu, then click either Signature or My Business Card. 

To include a sound in a message.

1. Click anywhere in the message window. 

2. On the Format menu, point to Background, and then click Sound. 

3. Enter the name of the file you want to include and the number of times you want the file to play. 

To insert a picture in a message.

1. In the message, click where you want the image to appear. 

2. On the Insert menu, click Picture, then click Browse to find the image file. 

3. Enter Layout and Spacing information for the image file as needed. 

Notes.

· If message recipients are not able to view your inserted images, click the Tools menu, and then click Options. Click the Send tab, click HTML Settings, and then make sure that Send pictures with messages is selected.  Then resend your message. 

· To insert a background picture in your message, in the message window, click the Format menu, point to Background, then click Picture. Click the Browse button to search for the file you want to use. 

Attaching files to e-mail messages.

Purpose.
· You can attach a copy of any type of file such as a document, spreadsheet, graphic image or a presentation to your e-mail messages.
1. Click the New Message button.
2. In the Message Composition dialog box, enter the e-mail address and type in the message to be sent.

3. Click where you want the file attachment to appear, then click the Insert File button to display the Insert File dialog box.
4. Locate the folder that contains the file you want to attach, and then click the file.  
To select multiple files, hold down the CTRL as you click each of the files.
5. Click the OK button.
The attached file is displayed as an icon in the body of the message.  The icon indicates the file type and name.  e.g., Sales Results.xls
6. Click the Send button.
To open or view the attached file.
Documents that contain file attachments display a paper clip image in the view or folder next to the document file.

Once the document is open, Microsoft Outlook displays an icon representing the attachment.
Note. You must have the application in which the attachment was composed in order to open it.  The MIME (Multi-purpose Internet Mail Extension) type of file enables Internet browsers to access an Internet mail file without prompting the user to specify the program used to create the attached file.
1. In the Inbox, select the e-mail message that contains the attachment.
2. Double-click the e-mail message to open it.

3. Double-click the icon that represents the attachment.
Deleting an attachment.

1. Open the e-mail message that contains the attachment.
2. To delete the attached file, click the file icon, then press the Delete key.

Organizing E-mail messages. 
Purpose.

· You can use Outlook Express to organize your incoming messages and make it easy to send mails.
To use your online time efficiently, use Outlook Express to find messages, automatically sort incoming messages into different folders, keep messages on a mail server, or delete them entirely.

Organizing the Inbox.
You can organize the messages in your Inbox quickly by sorting them.

To quickly sort messages by Subject, Sender or the Date received, click on the respective column header.  E.g., to sort your messages in alphabetical order by sender, click on From in the column header.
To create a Mail folder.

1. On the File menu, click New, then choose Folder.
2. Enter the name of the folder in the Name box, e.g., My Own.

3. Select the Inbox folder so that the mail folder created will become a subfolder of the Inbox.
4. You can add details, such as a description of the folder in the Description box, then click OK.
To move or copy a message to another folder.

1. In the message list, select the message (s) you want to move or copy. 

2. On the Edit menu, click Move to Folder or Copy to Folder, then select the folder you want to move or copy the message to. 

To delete a mail message.

1. In the message list, select the message. 

2. On the toolbar, click the Delete button (or press the Delete key). 

Notes.

· To restore a deleted message, open the Deleted Items folder, and then drag the message back to the Inbox or other folder. 

· If you don't want messages to be saved in the Deleted Items folder when you quit Outlook Express, 

1. Click the Tools menu, then click Options. 

2. On the Maintenance tab, select the checkbox labeled Empty messages from the 'Deleted Items' folder on exit. 

· To manually empty all deleted items, 

1. Select the Deleted Items folder. 
2. On the Edit menu, click Empty Deleted Items Folder. 

Sending a Web page by e-mail.

Purpose.

· You may find some interesting and useful material on the Internet that you would like to share with friends and colleagues.
You can send Web pages by e-mail to other people even if the recipients are not connected to the Internet.

1. Access the Web page you want to send.

2. Click the File menu, point to Send, then click Page By E-mail or Link By E-mail. 

3. If necessary, choose the correct profile to use from the Profile dialog box, i.e., Outlook Express, and click OK. 

4. In the Message dialog box, enter the address of the recipient, then click the Send button.

Note. You must have an e-mail account and an e-mail program set up on your computer. 

Blocking Unwanted messages.
You can control the mail and news messages you get in Outlook Express . You can block certain people from sending you mail, you can hide conversations that don't interest you, and you can guard against being sent damaging code in mail by setting security levels. 

To block messages from a sender or domain.

You can block messages from a particular sender or domain. 

· The Domain is the name following the @ symbol in an e-mail address. 

· Domain - A group of networked computers that share information & resources.

When you block a sender or domain, no e-mail or news message from that sender or domain will arrive in your Inbox or in the news messages you read. 

E-mail from blocked senders goes directly into your Delete folder while Newsgroup messages from blocked senders are not displayed. 

1. From your e-mail Inbox or the list of messages in a newsgroup, select a message from a sender you want to block. 

2. On the Message menu, click Block Sender. 

The e-mail address of the sender will appear in the Address box. You can type a different address or domain in the Address box if you wish. 

3. Select the blocking option you want: mail, news, or both kinds of messages. 

Important.  Blocking a sender applies to standard POP mail only. It does not apply to HTTP mail (Hotmail) or IMAP messages

Differences between E-mail and General Post office mail.

1). E-mail is computerized, while Post office mail is manually operated.

2). Post office mail is slow, while E-mail is fast & has a wide area of coverage.

3). E-mail is more secure.

Advantages of E-mail.

Electronic mail has several advantages over regular mail.

(i). It is cheap & economical.  

It costs almost nothing to transmit an e-mail message over the network, i.e., there is no need for stamps, envelopes, etc.

(ii). It is secure, i.e., access to a user’s mailbox can be restricted by use of a password.

(iii). It is faster, i.e., mails can be sent instantly.  

The delivery of an e-mail message normally takes seconds or minutes, depending on the distance to the receiver.

(iv). It is efficient, i.e., a message prepared only once can be sent to several people.

(v). It is convenient.

With E-mail, you can send your messages when it is convenient for you and your recipients respond at their convenient times.
(vi). E-mail is cheaper in terms of the time invested in preparing the message.

The expectations and culture of sending & receiving e-mail are different from that of sending regular letters.  Regular business letters & inter-office memos are expected to be error-free and formatted according to certain standards.  In contrast, most e-mail users accept less well-formatted messages and slight typographical errors are overlooked. So, less time is spent perfecting the appearance of the message.

(vii). E-mail can act as a substitute for the Telephone calls, thus allowing the user to avoid telephone tag (i.e., the process of repeatedly exchanging voice mail messages because you or the other person may not be available when the other calls).

E-mail can often communicate enough of a message so that the entire “conversation” will take less time than a phone call.

E-mail is particularly effective for multinational organizations, which have people working in different time zones around the world.
Disadvantages of E-mail.

(i). The initial installation cost is higher.

(ii). Messages may be lost before they are read due to virus infections.

(iii). Messages may not be kept for future reference due to the high cost of storage, i.e., it requires regular deletion of messages from the hard disk.

Exercise.

1. How does one send an e-mail message?

2. What is the advantage of filing e-mail messages when you can leave them in the Inbox and still have them for future reference?

3. List THREE levels of importance one can set on an e-mail message.

4. Lucille has received an e-mail message that contains an attachment.  Can she use any application to open the attached file? Explain.

5. What are the advantages of e-mail over the ordinary post office mail.

6. Give THREE differences between electronic mail and the Post office mail?
Using the Address Book.

Purpose.
· The Address Book is a directory of personal details, including e-mail addresses, for the people to whom you send messages (called Contacts).
It is used to store/keep track of e-mail addresses, mailing addresses, phone numbers, and other information about your friends and also provides space for notes.

You can store such addresses in the Address Book so as to address mails more easily, i.e., each time you want to send e-mail messages, you simply select the names from the list of addresses.
This will save the time used to enter lists of e-mail addresses as well as help maintain their accuracy.  E.g., an e-mail address like Njiiri.mworia@mit.edu.uk can be difficult to remember.  In addition, one can easily make a typing error when typing the address.
The Address Book is accessible from Internet Explorer, Outlook Express and NetMeeting, thus enabling you to keep one list of addresses that are accessible by various programs.

To add a contact to the Address Book.

1. To open the Address Book, click the Address Book button.
There can be several types of address books in the Address Book dialog box including the Global Address list and Personal Address Book. 

2. In the Show names from the box, select the type of address book you want to use. 

The Global Address list is the address book that contains all e-mail addresses for users, groups, and distribution lists in your organization that you can address messages to.  The Administrator creates and maintains this address book.
The Personal Address Book is the address book used to store personal distribution lists you frequently address messages to, such as a list of your friends.

3. Click the New Entry button.
4. Specify the entry type of the contact, i.e., whether it is an Internet address or an entry for a distribution list.

5. Type in the display name for the address as well as the full e-mail address.

6. Complete the dialog box with the rest of the contact details using the other tabs, e.g., Business or Phone Numbers, then click OK.
The contact address is added to the Address Book.

To edit a contact in the Address Book.

1. Open the Address Book.

2. Select the contact that you want to edit.

3. On the File menu, click Properties.
4. Make the necessary changes to the information, then click OK.

To create a contact from a mail message.

When you receive a mail message, you can add the sender’s details (name and e-mail address) to your Address Book.

1. From the Inbox, right-click a message.

2. Select Add sender to Address Book, from the shortcut menu that appears.

To delete a contact from the Address Book.

1. Open the Address Book.

2. Select the address that you want to remove from the Address book.

3. Click the Delete button (or press the Delete key).

4. Click Yes to confirm that you want to delete the name or entry.

To create a distribution list.

If you send mails to the same group of people frequently, you can create a group address list.  Group address lists are known as Distribution lists.

When you address a message to that group, each individual in the group receives it.  
Note.  You must have a Personal Address Book set up in order to be able to create a personal distribution list.

1. Open the Address Book.

2. Click the New Entry button.
3. In the Select the entry type box, click Personal Distribution List, and then click OK.
4. In the Name box, type a name for the group, e.g. Sales Dept., then click the Add/Remove Members button.

5. To add members to the group, select a contact or name from the left hand list box, then click the Members button (or double-click on a name) to move the name to the right list box.
The contact is copied to the Personal Distribution List box.

6. Repeat step 5 until you have all the names you want in your group in the Personal Distribution List, then click OK.
The group or distribution list is usually listed in the Address Book.

To send a message using the Address Book or distribution list.

1. In the Microsoft Outlook window, click File then select the New Mail Message.

2. Click the To… button to open the Address Book. 

3. Select the contact names from the list or select the distribution list, then click on To ->.

Note. To see the full e-mail addresses, select the name of the person from the lists and click on Properties button.

4. Click OK to return to the message composition dialog box.
5. Type out the rest of the message and click on Send.

Exercise.

1. What are the advantages of using the Address Book as opposed to typing e-mail addresses each time you send e-mail?

READING MAIL MESSAGES OFFLINE.

Once you have opened the E-mail program, it is not necessary for you to be connected directly so that you can read & write your e-mail messages.  You may choose to work offline to save on costs. 

When you are offline, Outlook Express downloads mail messages to your local computer. When you connect (or choose to work online) again, messages in your Outbox are sent, messages you marked for deletion are removed, and all other actions taken offline are completed at once.

There are 2 situations where it is beneficial to use Outlook Express offline: 

(i). If your ISP charges you by the hour or if you have only one phone line.  Under these conditions, you might want to reduce time spent online. 

(ii). If you use a Laptop to read your messages while you are traveling or any other time you are not connected to the Internet.

To set up Outlook Express to reduce online time.

1. On the Tools menu, click Options. 

2. On the Connection tab, select Hang up after sending and receiving. 

If you connect to an IMAP or HTTP server, click the server name in the folder list, and then make sure that the items you want to view offline are checked. 

This procedure can be used to set up Outlook Express so that it automatically disconnects after you select Send and Receive from the Tools menu. 

You can then read and compose messages offline without incurring charges or tying up a phone line. 

Note.  To reconnect to send or receive messages, click the Tools menu, point to Send and Receive, and then select the option you want. 

To read messages while you are away from your Internet connection.

1. On the Tools menu, select Options, then click the General tab.

2. Under the field labeled If my computer is not connected at this time, select Connect only when not working offline. 

If you connect to an IMAP or http server, click the server name in the folder list, make sure

that the items you want to view offline are checked, and then click Sync Account. 

3. On the File menu, click Work Offline. 

Note.  To check the type of account you have, click the Tools menu, and then click Accounts. Select your e-mail account and then click Properties. The account type is listed on the Advanced tab. 

Viewing and posting to Newsgroups.
What are newsgroups?

A Newsgroup is a collection of messages posted by individuals to a News server (a computer that can host thousands of newsgroups).

Some newsgroups are "owned" by someone who reviews the postings, can answer questions, delete inappropriate messages, etc. 
Anyone can post messages to a newsgroup. This is because, Newsgroups do not require any kind of membership or joining fees.

To use newsgroups in Outlook Express, your Internet Service Provider must offer links to a news server. After you set up an account for the server you want in Outlook Express, you can read and post messages in any of the newsgroups stored on that news server. 

To switch between mail and news reading.

· In the Folders list, click Inbox to go to your e-mail, or click a news server name or specific newsgroup to visit newsgroups. 

To find newsgroups of interest.

1. In the Folders list, click a server name, then click the Newsgroups button. 

2. In the Display newsgroups which contain box, type the words you want to search for. 

To subscribe to a newsgroup.

Subscribing ensures that the newsgroup is included in your Folders list for easy access.

You can subscribe to a newsgroup in any of the following ways:

(a). When adding a news server, Outlook Express prompts you to subscribe to newsgroups on that server. 

(b). Click a news server name in your Folders list, and then click the Newsgroups button. Select the newsgroup that you want to subscribe to, and then click the Subscribe button.

Note: When you double-click a name in the Newsgroup list, a subscription is automatically generated. 

(c). When you click a newsgroup, its name appears in your Folders list. Right-click the name, and then click Subscribe. 

Tips.  To cancel your subscription to a newsgroup, 

1. Click the Newsgroups button, click the Subscribed tab, select the group you want, and then click the Unsubscribe button. 

-Or- 

Right-click the newsgroup in your Folders list, then click Unsubscribe. 

To view a newsgroup without subscribing to it.

To find out if a specific newsgroup is right for you, read some of the messages in it. 

1. From the Tools menu, select Newsgroups to open the Newsgroup Subscriptions dialog box. 

2. Select the news server you want in the Accounts list.  All of the newsgroups on that server appear on the All tab. 

3. Select the newsgroup you want to view, and then click Go To. 

Note.  The first time you view a newsgroup, it may take several minutes to download the messages. The next time you go to that newsgroup, it downloads faster, because Outlook Express downloads only new messages. 

To read newsgroup messages.

Go to a newsgroup and look through the message list for a message you want to read (you may need to scroll). 

· To view the message in the preview pane, click the message once. 

· To view the message in a separate window, double-click the message in the message list. 

To read and send international messages.

Outlook Express can usually display messages in the language in which they were sent. However, some messages, particularly those from newsgroups, often do not have enough information (or the information is incorrect) in the header file to display the correct language. 

To change the language encoding for a message you are reading.

· In the message window, click the View menu, point to Encoding, and then click the language encoding you want to use. 

To set the default encoding for reading messages.

1. On the Tools menu, click Options.  On the Read tab, click Fonts. 

2. Select a language at the top, and then click the Set as Default button. 

Posting messages to newsgroups.

There are several ways that you can post messages, depending on whether you are posting a new message or replying to one and how widely you want it distributed. 

1. In the Folders list, select the newsgroup you want to post a message to. 

2. On the toolbar, click the New Post button. 

Note. To send your message to multiple newsgroups on the same news server, click the icon next to Newsgroups in the New Message dialog box. In the Pick Newsgroups dialog box, hold down the CTRL key to select multiple newsgroups, and then click Add. 

3. Type the Subject of your message. Outlook Express cannot post a message that does not contain a subject. 

4. Compose your message, and then click the Send button. 

To reply to a newsgroup message.

1. In the message list, click the message you want to reply to. 

2. To reply to the author of the message by e-mail, click the Reply button on the toolbar. 

To reply to the whole newsgroup, click the Reply Group button on the toolbar. 

3. Type your message, and then click Send. 

Note.  To view information about a newsgroup message, such as when it was sent, select the message, click the File menu, and then click Properties. 

To prevent newsgroup messages from automatically downloading.

On the Tools menu, click Options. 

On the Read tab, clear the following check box: Automatically download messages when viewing in the Preview Pane. 

To view newsgroups efficiently.

View only unread news messages in a newsgroup.

1. Open the newsgroup, click the View menu, point to Current View, and then click Hide Read Messages. 

View the replies to a particular message in a newsgroup.

1. Click the plus sign ( + ) next to the message. The replies to that message appear below it. A message with its replies is called a "conversation." 

To watch a conversation.

In both mail and news, you can watch a conversation that is of particular interest you. A conversation is an original message and all its replies. 

1. In your Inbox or newsgroup message list, select the conversation you wish to watch.

2. On the Message menu, click Watch Conversation. 

If your message list's Watch/Ignore column is turned on, the watch icon will appear next to all the messages of a watched conversation.

READING NEWSGROUP MESSAGES OFFLINE.
Offline newsreading enables you to read newsgroup messages without being connected to the Internet, saving connection costs. 
To do this,  you must subscribe to the newsgroup whose messages you want to read offline, mark it to specify whether you want to see headers or whole messages, and then transfer them to your computer (synchronize). Once this is done, you can log off from the Internet and then read the messages at your leisure. 

Reading message headers only, gives you the subject, author, and size of the message. 
To set up newsgroups for offline news reading.

For newsgroups you subscribe to, you can set up Outlook Express to make messages or headers available offline by synchronizing. This enables you to read them at your leisure when you are not connected to the Internet. 

1. From the Folders list, select a news server. 

2. In the main window, select one or more newsgroups you subscribe to whose messages you want to read offline. (To select multiple newsgroups, hold down the CTRL key while you click the newsgroups.) 

3. Click the Settings button, and then click to mark what you want transferred from the server to your computer during synchronization: 
· All Messages, 
· New Messages Only (new to the server since you last synchronized), or 
· Headers Only (subject, author, date, and size of message). 

4. Click the Sync Account button. 

Exercise.

1. (a). When can you work offline?

(b). Why should you work offline?

Methods of Accessing Computer and Locating Files.

(1). Gopher:
This is a client/server tool that enables the user to locate almost all textual information stored on Internet servers through a series of easy-to-use or understand, hierarchical menus that provide point-and-click interfaces.
The Internet has thousands of Gopher server sites throughout the world.  Each gopher site contains its own system of menus listing related topics, local files, and other relevant gopher sites.
To search for a specific topic or select a related item from a menu, activate the gopher software.  The server will automatically transfer you to the appropriate file on that server or the selected server wherever it is located in the world.  Once on the distant server, you are presented with more menus of files and Internet addresses of other gopher site servers that might interest you.  You can then move from site to site locating information that you want anywhere in the world.  After finding the information or files you want, you are free to browse, read them online, or download them onto your own computer for searching for text that appears in gopher menus.
(2). Archie:

This is a tool for locating data on the Internet that performs keyword searches of an actual database of documents, software, and data files available for downloading from servers around the world.
An individual Archie database can list only a small percentage of the files in the world.  However, clicking on the relevant listing from one Archie server will bring you to another computer system where relevant files are stored.  While on the other computer, the Archie server may provide other relevant references, allowing you to continue your search for related files, moving from database to database, library to library, until you locate what you need.
Archie database searching uses the subject keywords entered such as “telecommuting” or “inflation” to display a list of sites that contain files on that topic.  Once you find the files you want, you may use a file transfer program to download them.
(3). WAIS (Wide Area Information Servers):

This is a tool for locating data on the Internet that require the name of the databases to be searched based on keywords.  
Once you specify specific database names and key identifying words, WAIS searches for the keywords in all the files in those databases.  When the search is completed, you are given a menu listing all the files that contain your keywords.
(4). The Word Video Web:
The Web is another information retrieval tool similar to gophers, Archie, and WAIS.  It is widely used for commercial purposes on the Net due to the fact that, it is attractive, easy to use, and helpful in publishing or providing information to anyone interested.
(5). Home Page:

Anyone willing to offer information through the Web must first establish a Home Page (a WWW text & graphical display that welcomes the user and explains the organization that has established the page).  The Home page will lead the user to other pages.
All the pages of an organization are known as a Website.

Home pages combine text, hypermedia, graphics and sound, unlike the other methods of locating information on the Net, which are text-based.  This means that, home pages can handle all types of communication, while making it easy to link resources that are far apart.  
Graphics allow organizations to communicate more effectively, making their own material more appealing to the eye, more informative, and easy to understand.
Hypermedia provides a point-and-click connection to related information within the same document, between documents on the same computer, or to documents located on another computer anywhere in the world (as long as the computer is connected to the Net, and the hypermedia connection has been programmed in).
Sound allows some of the Web displays to talk or play music.  
Note.  The specific hypermedia technology used in the Web is known as Hyperlinks.
Within any web document, there are certain words or graphics that are highlighted (usually appear bold, in a different colour, underlined, or a combination of these).  The highlighted objects have hyperlinks embedded within them that contain the path to another location within the same document, a document on the same computer, or a document on another computer.  

Hyperlinks allow the user to move with ease within complex documents or across the network.  If the reader of the document wants more information on the highlighted word, he/she double-clicks the word, and quickly that other information will be displayed, even if it is stored in another part of the world.
Advantages of Hyperlinks.

(i). It is easy to use.
(ii). The user is free to jump from place to place following his/her own logic and interest, and does not have to move according to a static, pre-programmed, linear sequence.

The user moves around almost as easily as a book reader might follow keywords and jump around an encyclopedia. 

To navigate the Web requires a graphics Computer to link to the Internet.  The user must also have a special software tool to navigate the Web known as Web Browser.
BENEFITS FROM THE USE OF THE INTERNET.
1). Reduces the Cost of Communication.
Before the Internet, organizations had to build their own Wide Area Networks or subscribe to Value-Added Network (VAN) service.  
Many organizations find the Internet more cost-effective than building their own networks or paying VAN subscription fees.  Organizations use the Internet to fulfill a wide range of communication needs.  This lowers other communication costs, including their network management expenses, telephone and Fax costs.
Reduced communication costs are beneficial particularly to small businesses because it sometimes enables them to compete with larger companies in the markets that would otherwise be closed to them.
2). Enhances Communication & Co-ordination.
Global companies use the Internet as an important instrument for coordinating their activities.  Such companies have set up internal Web sites to keep employees informed about company developments.  Through the Web, employees are able to see a company Calendar, the employee Policy manual, product Brochures, interactive Training tools, and even stock quotes.
The Internet has made it easier and less expensive for companies to co-ordinate small staffs when opening new markets or working in isolated places, because they do not have to build their own networks.
3). Accelerates the Distribution of Knowledge.
To speed product development and also to react to an emerging problem, information gathering must be quick and easy.  

The Internet is very useful in the modern society, which is increasingly dependent on knowledge.  Organizations are using E-mail and the availability of databases all over the world to gain access to information in such areas as Business, Science, Law, and Government.  The Internet can quickly link a computer user sitting at a computer screen to mountains of data (including Graphics) all over the world, which would otherwise be too expensive and too difficult to get.
4). Improves Customer service and satisfaction.
Organizations can also use the Internet to communicate efficiently to make product information, ordering and technical support easier and immediately available.  
A company can establish a Website on the Internet in order to distribute useful product information to its customers and product users.  It can also use the Internet to give engineering support to its customers without the involvement of engineering staff.
5). Facilitates Sales and Marketing.
The Internet provides opportunities for firms to market and sell their products in a way that does not offend others.  This is because, the Internet is a passive instrument, i.e., it requires potential customers to seek out offerings by companies rather than having those companies actively reach out to potential customers, as is the case in most marketing and advertising.
Retailers update their Web page offerings frequently as required.  Suppliers can also update technical materials used by customers easily.  Therefore, the Internet assist buyers and sellers make contacts.  

Firms use their Websites to distribute more marketing information.  A firm can include its Web address in product advertisements and design their site for visitors to browse information on pricing, press releases on new products, technical manuals and sales brochures.
PROBLEMS FACING THE INTERNET.

1). Lack of Security.

Lack of security is one of the reasons why the Internet, while being widely used to facilitate transactions, is still in limited use to carry out transactions.
When large amounts of data are stored in electronic form, they are exposed to more kinds of threats/dangers than when they exist in manual form.
Through data communication networks, information systems in different locations on the Internet are interconnected.  The potential for unauthorized access, abuse or fraud is not limited to a single location but can occur at any access point in the Internet.  
Internet Hackers have found ways of stealing passwords as they pass through one site and use them to break into computer system at other sites all over the world.
The hackers can get access to company’s strategic business plans, profit reports, product development information, pricing data, marketing plans, sales contracts, and scientific research data.  Such information is too sensitive and companies are unwilling to have it accessed by unauthorized people.
2). Technology Problems.

(a). The Internet lacks standards for accessing the net and sending e-mails.  A no. of incompatible ways for accessing the net exist, allowing specific users to perform certain functions but not others.  
(b). The lack of standards also affects the ability of organizations to establish a stable link to the Internet.  As the traffic on the Internet becomes more complex, it can bring problems if it does not have good technical support.
(c). Many people and organizations are sending so much data through the Net, much of it in graphics form, such that telecommunication links are already overloaded.  Frequent users are unable to access the net, while those who use the graphics-based Web regularly find connecting to the intended Server very slow or even almost impossible during busy times.
(d). Moreover, the growing need for bandwidth due to graphics will only expand as the transmission of sound and full-motion video expands.  All this is raising the cost of using the Net.  Some firms are already discovering that they need more expensive telecommunications connections, Workstations or higher speed computers with improved graphics capability, and even Information system specialists with skills related specifically to the Internet.
(e). Individuals and organizations in less developed countries with poor Telephone lines, limited hardware and software capacity or Government controls on communication will not be able to take full advantage of Internet resources.

(f). Due to the fact that there is no a comprehensive method of locating and keeping track of pages in the World Wide Web (www), Internet users often spend a lot of time in futile (unsuccessful) searches, despite the many new tools and planned indexes to the Web.  There is no good technology enough to filter/sort out irrelevant information while allowing people to access the specific information they need. 
3). Legal Issues.

Until a greater clarity on several legal issues is obtained, doing business on the Internet will become unreliable.
Laws governing E-commerce are mostly non-existing or are just being written.  
There are several open questions that still exist such as, the legality of E-mail contracts, the role of electronic signatures, and the application of copyright laws to electronically copied documents. 

4). Anti-Commercial culture.

Initially, the Internet was a scientific and academic tool.  As it grew, a strong anti-commercial culture grew with it.  

Internet users have shown themselves unwilling to accept the Internet mail.  Many commercial users also fear that allowing commercial organizations to add very many unasked for marketing messages will make the Internet E-mail difficult to manage.  
Thus, while businesses remain free to use the Internet for E-mail, research, and other forms of information exchange, they will have to learn new ways to do their marketing on the Internet; ways that do not offend the other users.
Exercise I.
1. State the various methods of accessing computer and locating files.

2. Describe the main benefits from the use of the Internet.
3. Give a brief view of the main problems of the Internet.

Exercise II.

1. Briefly describe four advantages of using Internet to disseminate information compared to other conventional methods.






(8 marks).

2. One of the problems of using Internet for business is insecurity.  What are some of the other problems and what controls should be put in place in order to solve the problems?. (4 marks).

3. Your manager wishes to be connected to the Internet.  He already has a powerful Personal Computer (PC), a Printer and access to a Telephone line.  However, he understands that he will need a Modem.

Required:

(a). State why a Modem is required to connect him to the Internet.

(2 marks).

(b). Suggest any four application areas in which you would expect a Supermarket retail manager to use the Internet.






(4 marks).
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